summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2020-05-29 17:54:39 +0200
committerBence Hornák2020-05-29 17:54:39 +0200
commitbb3ba09e97a59f8d2eea6fa9c77816131d6e5539 (patch)
treed34f5648ca2b6b345a19a210b34d1eee66544616
parent742cad81350b1d1cdb816f090cb14e115d89f976 (diff)
parentf206fd79b02ce76a825ca605e1dcf64b1fbc3d2e (diff)
downloadaur-bb3ba09e97a59f8d2eea6fa9c77816131d6e5539.tar.gz
Version 1.2.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--.yarnclean62
-rw-r--r--PKGBUILD19
-rw-r--r--package.json150
-rwxr-xr-xtheia-electron.sh (renamed from theia-electron)2
5 files changed, 190 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b46b7a4e281..ae10261f1882 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.1.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://www.theia-ide.org/
arch = any
@@ -18,13 +18,15 @@ pkgbase = theia-electron
depends = libxkbfile
optdepends = git: git support
options = !strip
- source = theia-electron
+ source = theia-electron.sh
source = package.json
+ source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.1.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.1.0/LICENSE
- md5sums = c022f460c0d928df6c1ece9d3044b008
- md5sums = e7f6ec77c96c13c45e5b691b539b1fca
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.2.0/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.2.0/LICENSE
+ md5sums = 5a26cc7b1b461bec8533266dbe64c87e
+ md5sums = d254be29e8f55f78d8f8d5d4801403d8
+ md5sums = 54b30057095cf131ec7296b0d0bd2046
md5sums = b316dead79fa33f45c8d689a1c940dab
md5sums = 1dde0e422484895d3509f4ee9bb8d980
md5sums = 6befbd553f609c8f4e48805013bc71c7
diff --git a/.yarnclean b/.yarnclean
new file mode 100644
index 000000000000..0200e5316e27
--- /dev/null
+++ b/.yarnclean
@@ -0,0 +1,62 @@
+################################################################################
+# yarn autoclean --init
+################################################################################
+# test directories
+__tests__
+test
+tests
+powered-test
+
+# asset directories
+docs
+doc
+website
+images
+assets
+
+# examples
+example
+examples
+
+# code coverage directories
+coverage
+.nyc_output
+
+# build scripts
+Makefile
+Gulpfile.js
+Gruntfile.js
+
+# configs
+appveyor.yml
+circle.yml
+codeship-services.yml
+codeship-steps.yml
+wercker.yml
+.tern-project
+.gitattributes
+.editorconfig
+.*ignore
+.eslintrc
+.jshintrc
+.flowconfig
+.documentup.json
+.yarn-metadata.json
+.travis.yml
+
+# misc
+*.md
+
+################################################################################
+# Custom
+################################################################################
+# theia build
+.eslintcache
+*.tsconfig.tsbuildinfo
+post-install.log
+
+# tests
+*.spec.js
+*.spec.js.map
+*.spec.d.ts
+*.spec.ts \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 357bf1110c89..e6f409ec7497 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bence Hornák <bence.hornak@gmail.com>
pkgname=theia-electron
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
@@ -13,14 +13,16 @@ optdepends=('git: git support')
options=(!strip) #to speed up build
source=(
- "theia-electron"
+ "theia-electron.sh"
"package.json"
+ ".yarnclean"
"theia-electron.desktop"
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/logo/theia.svg"
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
-md5sums=('c022f460c0d928df6c1ece9d3044b008'
- 'e7f6ec77c96c13c45e5b691b539b1fca'
+md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
+ 'd254be29e8f55f78d8f8d5d4801403d8'
+ '54b30057095cf131ec7296b0d0bd2046'
'b316dead79fa33f45c8d689a1c940dab'
'1dde0e422484895d3509f4ee9bb8d980'
'6befbd553f609c8f4e48805013bc71c7')
@@ -36,15 +38,14 @@ package() {
# Create directory
install -dm 755 "$pkgdir"/usr/lib/$pkgname
- # Source code (symlinks are not dereferenced)
+ # Source code (symlinks are not dereferenced) and plugins
cp -r --no-preserve=ownership --preserve=mode \
- src-gen lib node_modules \
+ src-gen lib node_modules package.json \
+ plugins \
"$pkgdir/usr/lib/$pkgname/"
- # package.json (should be dereferenced)
- install -Dm644 package.json "$pkgdir/usr/lib/$pkgname/"
# Executable
- install -Dm755 theia-electron "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 theia-electron.sh "$pkgdir/usr/bin/$pkgname"
# Desktop file
install -Dm644 theia-electron.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
# Icon
diff --git a/package.json b/package.json
index 498fbdd279fd..92c5dbde4085 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.1.0",
+ "version": "1.2.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -11,51 +11,119 @@
}
}
},
+ "theiaPluginsDir": "plugins",
+ "theiaPlugins": {
+ "vscode-builtin-bat": "https://open-vsx.org/api/vscode/bat/1.44.2/file/vscode.bat-1.44.2.vsix",
+ "vscode-builtin-clojure": "https://open-vsx.org/api/vscode/clojure/1.44.2/file/vscode.clojure-1.44.2.vsix",
+ "vscode-builtin-coffeescript": "https://open-vsx.org/api/vscode/coffeescript/1.44.2/file/vscode.coffeescript-1.44.2.vsix",
+ "vscode-builtin-configuration-editing": "https://open-vsx.org/api/vscode/configuration-editing/1.44.2/file/vscode.configuration-editing-1.44.2.vsix",
+ "vscode-builtin-cpp": "https://open-vsx.org/api/vscode/cpp/1.44.2/file/vscode.cpp-1.44.2.vsix",
+ "vscode-builtin-csharp": "https://open-vsx.org/api/vscode/csharp/1.44.2/file/vscode.csharp-1.44.2.vsix",
+ "vscode-builtin-css": "https://open-vsx.org/api/vscode/css/1.44.2/file/vscode.css-1.44.2.vsix",
+ "vscode-builtin-debug-auto-launch": "https://open-vsx.org/api/vscode/debug-auto-launch/1.44.2/file/vscode.debug-auto-launch-1.44.2.vsix",
+ "vscode-builtin-docker": "https://open-vsx.org/api/vscode/docker/1.44.2/file/vscode.docker-1.44.2.vsix",
+ "vscode-builtin-emmet": "https://open-vsx.org/api/vscode/emmet/1.44.2/file/vscode.emmet-1.44.2.vsix",
+ "vscode-builtin-fsharp": "https://open-vsx.org/api/vscode/fsharp/1.44.2/file/vscode.fsharp-1.44.2.vsix",
+ "vscode-builtin-go": "https://open-vsx.org/api/vscode/go/1.44.2/file/vscode.go-1.44.2.vsix",
+ "vscode-builtin-groovy": "https://open-vsx.org/api/vscode/groovy/1.44.2/file/vscode.groovy-1.44.2.vsix",
+ "vscode-builtin-grunt": "https://open-vsx.org/api/vscode/grunt/1.44.2/file/vscode.grunt-1.44.2.vsix",
+ "vscode-builtin-gulp": "https://open-vsx.org/api/vscode/gulp/1.44.2/file/vscode.gulp-1.44.2.vsix",
+ "vscode-builtin-handlebars": "https://open-vsx.org/api/vscode/handlebars/1.44.2/file/vscode.handlebars-1.44.2.vsix",
+ "vscode-builtin-hlsl": "https://open-vsx.org/api/vscode/hlsl/1.44.2/file/vscode.hlsl-1.44.2.vsix",
+ "vscode-builtin-html": "https://open-vsx.org/api/vscode/html/1.44.2/file/vscode.html-1.44.2.vsix",
+ "vscode-builtin-ini": "https://open-vsx.org/api/vscode/ini/1.44.2/file/vscode.ini-1.44.2.vsix",
+ "vscode-builtin-jake": "https://open-vsx.org/api/vscode/jake/1.44.2/file/vscode.jake-1.44.2.vsix",
+ "vscode-builtin-java": "https://open-vsx.org/api/vscode/java/1.44.2/file/vscode.java-1.44.2.vsix",
+ "vscode-builtin-javascript": "https://open-vsx.org/api/vscode/javascript/1.44.2/file/vscode.javascript-1.44.2.vsix",
+ "vscode-builtin-json": "https://open-vsx.org/api/vscode/json/1.44.2/file/vscode.json-1.44.2.vsix",
+ "vscode-builtin-less": "https://open-vsx.org/api/vscode/less/1.44.2/file/vscode.less-1.44.2.vsix",
+ "vscode-builtin-log": "https://open-vsx.org/api/vscode/log/1.44.2/file/vscode.log-1.44.2.vsix",
+ "vscode-builtin-lua": "https://open-vsx.org/api/vscode/lua/1.44.2/file/vscode.lua-1.44.2.vsix",
+ "vscode-builtin-make": "https://open-vsx.org/api/vscode/make/1.44.2/file/vscode.make-1.44.2.vsix",
+ "vscode-builtin-markdown": "https://open-vsx.org/api/vscode/markdown/1.44.2/file/vscode.markdown-1.44.2.vsix",
+ "vscode-builtin-markdown-language-features": "https://open-vsx.org/api/vscode/markdown-language-features/1.39.1/file/vscode.markdown-language-features-1.39.1.vsix",
+ "vscode-builtin-merge-conflict": "https://open-vsx.org/api/vscode/merge-conflict/1.44.2/file/vscode.merge-conflict-1.44.2.vsix",
+ "vscode-builtin-npm": "https://open-vsx.org/api/vscode/npm/1.39.1/file/vscode.npm-1.39.1.vsix",
+ "vscode-builtin-node-debug": "https://github.com/theia-ide/vscode-node-debug/releases/download/v1.35.3/node-debug-1.35.3.vsix",
+ "vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.33.0/file/ms-vscode.node-debug2-1.33.0.vsix",
+ "vscode-builtin-objective-c": "https://open-vsx.org/api/vscode/objective-c/1.44.2/file/vscode.objective-c-1.44.2.vsix",
+ "vscode-builtin-perl": "https://open-vsx.org/api/vscode/perl/1.44.2/file/vscode.perl-1.44.2.vsix",
+ "vscode-builtin-powershell": "https://open-vsx.org/api/vscode/powershell/1.44.2/file/vscode.powershell-1.44.2.vsix",
+ "vscode-builtin-pug": "https://open-vsx.org/api/vscode/pug/1.44.2/file/vscode.pug-1.44.2.vsix",
+ "vscode-builtin-python": "https://open-vsx.org/api/vscode/python/1.44.2/file/vscode.python-1.44.2.vsix",
+ "vscode-builtin-r": "https://open-vsx.org/api/vscode/r/1.44.2/file/vscode.r-1.44.2.vsix",
+ "vscode-builtin-razor": "https://open-vsx.org/api/vscode/razor/1.44.2/file/vscode.razor-1.44.2.vsix",
+ "vscode-builtin-ruby": "https://open-vsx.org/api/vscode/ruby/1.44.2/file/vscode.ruby-1.44.2.vsix",
+ "vscode-builtin-rust": "https://open-vsx.org/api/vscode/rust/1.44.2/file/vscode.rust-1.44.2.vsix",
+ "vscode-builtin-scss": "https://open-vsx.org/api/vscode/scss/1.44.2/file/vscode.scss-1.44.2.vsix",
+ "vscode-builtin-shaderlab": "https://open-vsx.org/api/vscode/shaderlab/1.44.2/file/vscode.shaderlab-1.44.2.vsix",
+ "vscode-builtin-shellscript": "https://open-vsx.org/api/vscode/shellscript/1.44.2/file/vscode.shellscript-1.44.2.vsix",
+ "vscode-builtin-sql": "https://open-vsx.org/api/vscode/sql/1.44.2/file/vscode.sql-1.44.2.vsix",
+ "vscode-builtin-swift": "https://open-vsx.org/api/vscode/swift/1.44.2/file/vscode.swift-1.44.2.vsix",
+ "vscode-builtin-theme-abyss": "https://open-vsx.org/api/vscode/theme-abyss/1.44.2/file/vscode.theme-abyss-1.44.2.vsix",
+ "vscode-builtin-theme-defaults": "https://open-vsx.org/api/vscode/theme-defaults/1.44.2/file/vscode.theme-defaults-1.44.2.vsix",
+ "vscode-builtin-theme-kimbie-dark": "https://open-vsx.org/api/vscode/theme-kimbie-dark/1.44.2/file/vscode.theme-kimbie-dark-1.44.2.vsix",
+ "vscode-builtin-theme-monokai": "https://open-vsx.org/api/vscode/theme-monokai/1.44.2/file/vscode.theme-monokai-1.44.2.vsix",
+ "vscode-builtin-theme-monokai-dimmed": "https://open-vsx.org/api/vscode/theme-monokai-dimmed/1.44.2/file/vscode.theme-monokai-dimmed-1.44.2.vsix",
+ "vscode-builtin-theme-quietlight": "https://open-vsx.org/api/vscode/theme-quietlight/1.44.2/file/vscode.theme-quietlight-1.44.2.vsix",
+ "vscode-builtin-theme-red": "https://open-vsx.org/api/vscode/theme-red/1.44.2/file/vscode.theme-red-1.44.2.vsix",
+ "vscode-builtin-theme-solarized-dark": "https://open-vsx.org/api/vscode/theme-solarized-dark/1.44.2/file/vscode.theme-solarized-dark-1.44.2.vsix",
+ "vscode-builtin-theme-tomorrow-night-blue": "https://open-vsx.org/api/vscode/theme-tomorrow-night-blue/1.44.2/file/vscode.theme-tomorrow-night-blue-1.44.2.vsix",
+ "vscode-builtin-typescript": "https://open-vsx.org/api/vscode/typescript/1.44.2/file/vscode.typescript-1.44.2.vsix",
+ "vscode-builtin-typescript-language-features": "https://open-vsx.org/api/vscode/typescript-language-features/1.44.2/file/vscode.typescript-language-features-1.44.2.vsix",
+ "vscode-builtin-vb": "https://open-vsx.org/api/vscode/vb/1.44.2/file/vscode.vb-1.44.2.vsix",
+ "vscode-builtin-icon-theme-seti": "https://open-vsx.org/api/vscode/vscode-theme-seti/1.44.2/file/vscode.vscode-theme-seti-1.44.2.vsix",
+ "vscode-builtin-xml": "https://open-vsx.org/api/vscode/xml/1.44.2/file/vscode.xml-1.44.2.vsix",
+ "vscode-builtin-yaml": "https://open-vsx.org/api/vscode/yaml/1.44.2/file/vscode.yaml-1.44.2.vsix",
+ "vscode-editorconfig": "https://open-vsx.org/api/EditorConfig/EditorConfig/0.14.4/file/EditorConfig.EditorConfig-0.14.4.vsix",
+ "vscode-eslint": "https://open-vsx.org/api/dbaeumer/vscode-eslint/2.1.1/file/dbaeumer.vscode-eslint-2.1.1.vsix",
+ "vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.47/file/ms-vscode.references-view-0.0.47.vsix"
+ },
"dependencies": {
- "@theia/callhierarchy": "1.1.0",
- "@theia/console": "1.1.0",
- "@theia/core": "1.1.0",
- "@theia/debug": "1.1.0",
- "@theia/editor": "1.1.0",
- "@theia/editor-preview": "1.1.0",
- "@theia/electron": "1.1.0",
- "@theia/file-search": "1.1.0",
- "@theia/filesystem": "1.1.0",
- "@theia/getting-started": "1.1.0",
- "@theia/git": "1.1.0",
- "@theia/json": "1.1.0",
- "@theia/keymaps": "1.1.0",
- "@theia/languages": "1.1.0",
- "@theia/markers": "1.1.0",
- "@theia/messages": "1.1.0",
- "@theia/metrics": "1.1.0",
- "@theia/mini-browser": "1.1.0",
- "@theia/monaco": "1.1.0",
- "@theia/navigator": "1.1.0",
- "@theia/outline-view": "1.1.0",
- "@theia/output": "1.1.0",
- "@theia/plugin-dev": "1.1.0",
- "@theia/plugin-ext": "1.1.0",
- "@theia/plugin-ext-vscode": "1.1.0",
- "@theia/preferences": "1.1.0",
- "@theia/preview": "1.1.0",
- "@theia/process": "1.1.0",
- "@theia/scm": "1.1.0",
- "@theia/scm-extra": "1.1.0",
- "@theia/search-in-workspace": "1.1.0",
- "@theia/task": "1.1.0",
- "@theia/terminal": "1.1.0",
- "@theia/typehierarchy": "1.1.0",
- "@theia/userstorage": "1.1.0",
- "@theia/variable-resolver": "1.1.0",
- "@theia/vsx-registry": "1.1.0",
- "@theia/workspace": "1.1.0"
+ "@theia/callhierarchy": "1.2.0",
+ "@theia/console": "1.2.0",
+ "@theia/core": "1.2.0",
+ "@theia/debug": "1.2.0",
+ "@theia/editor": "1.2.0",
+ "@theia/editor-preview": "1.2.0",
+ "@theia/electron": "1.2.0",
+ "@theia/file-search": "1.2.0",
+ "@theia/filesystem": "1.2.0",
+ "@theia/getting-started": "1.2.0",
+ "@theia/git": "1.2.0",
+ "@theia/json": "1.2.0",
+ "@theia/keymaps": "1.2.0",
+ "@theia/languages": "1.2.0",
+ "@theia/markers": "1.2.0",
+ "@theia/messages": "1.2.0",
+ "@theia/metrics": "1.2.0",
+ "@theia/mini-browser": "1.2.0",
+ "@theia/monaco": "1.2.0",
+ "@theia/navigator": "1.2.0",
+ "@theia/outline-view": "1.2.0",
+ "@theia/output": "1.2.0",
+ "@theia/plugin-dev": "1.2.0",
+ "@theia/plugin-ext": "1.2.0",
+ "@theia/plugin-ext-vscode": "1.2.0",
+ "@theia/preferences": "1.2.0",
+ "@theia/preview": "1.2.0",
+ "@theia/process": "1.2.0",
+ "@theia/scm": "1.2.0",
+ "@theia/scm-extra": "1.2.0",
+ "@theia/search-in-workspace": "1.2.0",
+ "@theia/task": "1.2.0",
+ "@theia/terminal": "1.2.0",
+ "@theia/typehierarchy": "1.2.0",
+ "@theia/userstorage": "1.2.0",
+ "@theia/variable-resolver": "1.2.0",
+ "@theia/vsx-registry": "1.2.0",
+ "@theia/workspace": "1.2.0"
},
"devDependencies": {
- "@theia/cli": "1.1.0"
+ "@theia/cli": "1.2.0"
},
"scripts": {
- "build": "electron-rebuild && theia build --mode production",
+ "build": "electron-rebuild && theia download:plugins && theia build --mode production",
"start": "theia start"
}
} \ No newline at end of file
diff --git a/theia-electron b/theia-electron.sh
index 39a6dcbf6db5..8a37be916237 100755
--- a/theia-electron
+++ b/theia-electron.sh
@@ -1,4 +1,4 @@
#!/usr/bin/env bash
/usr/lib/theia-electron/node_modules/.bin/electron /usr/lib/theia-electron \
- "--plugins=local-dir:$HOME/.theia/plugin-storage/" \
+ "--plugins=local-dir:/usr/lib/theia-electron/plugins" \
"$@" \ No newline at end of file