summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2020-04-18 17:55:00 +0200
committerBence Hornák2020-04-18 17:55:00 +0200
commitc3e7b4b83077339a44bd039099b41d509a63d862 (patch)
tree4633b88ac9e8b9759c920a7fa3f0685eae404325
downloadaur-c3e7b4b83077339a44bd039099b41d509a63d862.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
-rw-r--r--package.json62
-rwxr-xr-xtheia-electron2
-rw-r--r--theia-electron.desktop12
5 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cab7cee43c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = theia-electron
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.theia-ide.org/
+ arch = any
+ license = EPL2
+ makedepends = yarn
+ depends = nodejs>=10.11.0
+ depends = nodejs<12
+ options = !strip
+ source = theia-electron
+ source = package.json
+ source = theia-electron.desktop
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.0.0/logo/theia.svg
+ md5sums = 3503b21ff57ffecfe428da5be1b21171
+ md5sums = 5eb49842d52aa16e7310064c0fef9900
+ md5sums = b316dead79fa33f45c8d689a1c940dab
+ md5sums = 1dde0e422484895d3509f4ee9bb8d980
+
+pkgname = theia-electron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..833593a135cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Bence Hornák <bence.hornak@gmail.com>
+
+pkgname=theia-electron
+pkgver=1.0.0
+pkgrel=1
+arch=('any')
+url='https://www.theia-ide.org/'
+license=('EPL2')
+depends=('nodejs>=10.11.0' 'nodejs<12')
+makedepends=('yarn')
+options=(!strip) #to speed up build
+
+source=(
+ "theia-electron"
+ "package.json"
+ "theia-electron.desktop"
+ "https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/logo/theia.svg"
+)
+md5sums=('3503b21ff57ffecfe428da5be1b21171'
+ '5eb49842d52aa16e7310064c0fef9900'
+ 'b316dead79fa33f45c8d689a1c940dab'
+ '1dde0e422484895d3509f4ee9bb8d980')
+
+build() {
+ yarn install
+ yarn build
+ # Remove dev dependencies
+ yarn install --production --ignore-scripts --prefer-offline
+}
+
+package() {
+ # Create directory
+ install -dm 755 "$pkgdir"/usr/lib/$pkgname
+ # Source code
+ cp -r --no-preserve=ownership --preserve=mode \
+ src-gen lib package.json node_modules \
+ "$pkgdir/usr/lib/$pkgname/"
+
+ # Executable
+ install -Dm755 theia-electron "$pkgdir/usr/bin/$pkgname"
+ # Desktop file
+ install -Dm644 theia-electron.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ # Icon
+ install -Dm644 theia.svg "$pkgdir"/usr/share/pixmaps/theia.svg
+}
diff --git a/package.json b/package.json
new file mode 100644
index 000000000000..766ff98f3a53
--- /dev/null
+++ b/package.json
@@ -0,0 +1,62 @@
+{
+ "private": true,
+ "version": "1.0.0",
+ "main": "src-gen/frontend/electron-main.js",
+ "license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
+ "theia": {
+ "target": "electron",
+ "frontend": {
+ "config": {
+ "applicationName": "Theia"
+ }
+ }
+ },
+ "dependencies": {
+ "@theia/callhierarchy": "1.0.0",
+ "@theia/console": "1.0.0",
+ "@theia/core": "1.0.0",
+ "@theia/debug": "1.0.0",
+ "@theia/editor": "1.0.0",
+ "@theia/editor-preview": "1.0.0",
+ "@theia/electron": "1.0.0",
+ "@theia/file-search": "1.0.0",
+ "@theia/filesystem": "1.0.0",
+ "@theia/getting-started": "1.0.0",
+ "@theia/git": "1.0.0",
+ "@theia/json": "1.0.0",
+ "@theia/keymaps": "1.0.0",
+ "@theia/languages": "1.0.0",
+ "@theia/markers": "1.0.0",
+ "@theia/messages": "1.0.0",
+ "@theia/metrics": "1.0.0",
+ "@theia/mini-browser": "1.0.0",
+ "@theia/monaco": "1.0.0",
+ "@theia/navigator": "1.0.0",
+ "@theia/outline-view": "1.0.0",
+ "@theia/output": "1.0.0",
+ "@theia/plugin-dev": "1.0.0",
+ "@theia/plugin-ext": "1.0.0",
+ "@theia/plugin-ext-vscode": "1.0.0",
+ "@theia/preferences": "1.0.0",
+ "@theia/preview": "1.0.0",
+ "@theia/process": "1.0.0",
+ "@theia/scm": "1.0.0",
+ "@theia/scm-extra": "1.0.0",
+ "@theia/search-in-workspace": "1.0.0",
+ "@theia/task": "1.0.0",
+ "@theia/terminal": "1.0.0",
+ "@theia/typehierarchy": "1.0.0",
+ "@theia/userstorage": "1.0.0",
+ "@theia/variable-resolver": "1.0.0",
+ "@theia/vsx-registry": "1.0.0",
+ "@theia/workspace": "1.0.0",
+ "rxjs": "6.0.0"
+ },
+ "scripts": {
+ "build": "electron-rebuild && theia build --mode production",
+ "start": "theia start"
+ },
+ "devDependencies": {
+ "@theia/cli": "1.0.0"
+ }
+} \ No newline at end of file
diff --git a/theia-electron b/theia-electron
new file mode 100755
index 000000000000..2316d4a33f26
--- /dev/null
+++ b/theia-electron
@@ -0,0 +1,2 @@
+#!/usr/bin/env bash
+/usr/lib/theia-electron/node_modules/.bin/electron /usr/lib/theia-electron "$@" \ No newline at end of file
diff --git a/theia-electron.desktop b/theia-electron.desktop
new file mode 100644
index 000000000000..4f537f1fe920
--- /dev/null
+++ b/theia-electron.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Theia (Electron)
+Comment=Cloud & Desktop IDE Platform
+GenericName=Text Editor
+Exec=/usr/bin/theia-electron %F
+Icon=theia
+Type=Application
+StartupNotify=false
+StartupWMClass=theia-electron
+Categories=Utility;TextEditor;Development;IDE;
+MimeType=text/plain;
+Keywords=theia;electron