summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2020-09-26 19:21:55 +0000
committerBence Hornák2020-09-26 19:21:55 +0000
commite2c45a713d4831d10daf44ce77105fc15de39630 (patch)
tree975c52f479ae1cc513617a17e6d4aeee9f96c558
parent4911a6afc6ab1857b3f102b4126f89bb22835b46 (diff)
downloadaur-e2c45a713d4831d10daf44ce77105fc15de39630.tar.gz
Version 1.6.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD8
-rw-r--r--package.json86
4 files changed, 57 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a054ca8e3b8..e1f877490771 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.5.0
+ pkgver = 1.6.0
pkgrel = 1
url = https://www.theia-ide.org/
arch = any
@@ -23,10 +23,10 @@ pkgbase = theia-electron
source = package.json
source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.5.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.5.0/LICENSE
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.6.0/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.6.0/LICENSE
md5sums = 5a26cc7b1b461bec8533266dbe64c87e
- md5sums = 6db9b981f8543c90db7666449c258631
+ md5sums = 9448b29ece4f003326d1d25756f4c364
md5sums = 54b30057095cf131ec7296b0d0bd2046
md5sums = b316dead79fa33f45c8d689a1c940dab
md5sums = 1dde0e422484895d3509f4ee9bb8d980
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b826ddb03dbe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+LICENSE
+theia.svg
+*.pkg.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index cc348663be09..d6d1674e2f0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bence Hornák <bence.hornak@gmail.com>
pkgname=theia-electron
-pkgver=1.5.0
+pkgver=1.6.0
pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
@@ -21,17 +21,17 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- '6db9b981f8543c90db7666449c258631'
+ '9448b29ece4f003326d1d25756f4c364'
'54b30057095cf131ec7296b0d0bd2046'
'b316dead79fa33f45c8d689a1c940dab'
'1dde0e422484895d3509f4ee9bb8d980'
'84e52389f141be88a24bcfdd44c91a19')
build() {
- yarn install --cache-folder "$srcdir/yarn-cache"
+ HOME="$srcdir/.electron-gyp" yarn install --cache-folder "$srcdir/yarn-cache"
yarn build
# Remove dev dependencies
- yarn install --cache-folder "$srcdir/yarn-cache" --production --ignore-scripts --prefer-offline
+ HOME="$srcdir/.electron-gyp" yarn install --cache-folder "$srcdir/yarn-cache" --production --ignore-scripts --prefer-offline
}
package() {
diff --git a/package.json b/package.json
index c712f6ce4819..5be2096bccb1 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.5.0",
+ "version": "1.6.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -37,6 +37,7 @@
"vscode-builtin-jake": "https://open-vsx.org/api/vscode/jake/1.44.2/file/vscode.jake-1.44.2.vsix",
"vscode-builtin-java": "https://open-vsx.org/api/vscode/java/1.44.2/file/vscode.java-1.44.2.vsix",
"vscode-builtin-javascript": "https://open-vsx.org/api/vscode/javascript/1.44.2/file/vscode.javascript-1.44.2.vsix",
+ "vscode-builtin-js-debug": "https://open-vsx.org/api/ms-vscode/js-debug/1.49.8/file/ms-vscode.js-debug-1.49.8.vsix",
"vscode-builtin-json": "https://open-vsx.org/api/vscode/json/1.46.1/file/vscode.json-1.46.1.vsix",
"vscode-builtin-json-language-features": "https://open-vsx.org/api/vscode/json-language-features/1.46.1/file/vscode.json-language-features-1.46.1.vsix",
"vscode-builtin-less": "https://open-vsx.org/api/vscode/less/1.44.2/file/vscode.less-1.44.2.vsix",
@@ -47,8 +48,8 @@
"vscode-builtin-markdown-language-features": "https://open-vsx.org/api/vscode/markdown-language-features/1.39.1/file/vscode.markdown-language-features-1.39.1.vsix",
"vscode-builtin-merge-conflict": "https://open-vsx.org/api/vscode/merge-conflict/1.44.2/file/vscode.merge-conflict-1.44.2.vsix",
"vscode-builtin-npm": "https://open-vsx.org/api/vscode/npm/1.44.2/file/vscode.npm-1.44.2.vsix",
- "vscode-builtin-node-debug": "https://github.com/theia-ide/vscode-node-debug/releases/download/v1.35.3/node-debug-1.35.3.vsix",
- "vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.33.0/file/ms-vscode.node-debug2-1.33.0.vsix",
+ "vscode-builtin-node-debug": "https://open-vsx.org/api/ms-vscode/node-debug/1.44.8/file/ms-vscode.node-debug-1.44.8.vsix",
+ "vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.42.1/file/ms-vscode.node-debug2-1.42.1.vsix",
"vscode-builtin-objective-c": "https://open-vsx.org/api/vscode/objective-c/1.44.2/file/vscode.objective-c-1.44.2.vsix",
"vscode-builtin-perl": "https://open-vsx.org/api/vscode/perl/1.44.2/file/vscode.perl-1.44.2.vsix",
"vscode-builtin-powershell": "https://open-vsx.org/api/vscode/powershell/1.44.2/file/vscode.powershell-1.44.2.vsix",
@@ -83,47 +84,48 @@
"vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.47/file/ms-vscode.references-view-0.0.47.vsix"
},
"dependencies": {
- "@theia/callhierarchy": "1.5.0",
- "@theia/console": "1.5.0",
- "@theia/core": "1.5.0",
- "@theia/debug": "1.5.0",
- "@theia/editor": "1.5.0",
- "@theia/editor-preview": "1.5.0",
- "@theia/electron": "1.5.0",
- "@theia/file-search": "1.5.0",
- "@theia/filesystem": "1.5.0",
- "@theia/getting-started": "1.5.0",
- "@theia/git": "1.5.0",
- "@theia/keymaps": "1.5.0",
- "@theia/markers": "1.5.0",
- "@theia/messages": "1.5.0",
- "@theia/metrics": "1.5.0",
- "@theia/mini-browser": "1.5.0",
- "@theia/monaco": "1.5.0",
- "@theia/navigator": "1.5.0",
- "@theia/outline-view": "1.5.0",
- "@theia/output": "1.5.0",
- "@theia/plugin": "1.5.0",
- "@theia/plugin-dev": "1.5.0",
- "@theia/plugin-ext": "1.5.0",
- "@theia/plugin-ext-vscode": "1.5.0",
- "@theia/plugin-metrics": "1.5.0",
- "@theia/preferences": "1.5.0",
- "@theia/preview": "1.5.0",
- "@theia/process": "1.5.0",
- "@theia/scm": "1.5.0",
- "@theia/scm-extra": "1.5.0",
- "@theia/search-in-workspace": "1.5.0",
- "@theia/task": "1.5.0",
- "@theia/terminal": "1.5.0",
- "@theia/typehierarchy": "1.5.0",
- "@theia/userstorage": "1.5.0",
- "@theia/variable-resolver": "1.5.0",
- "@theia/vsx-registry": "1.5.0",
- "@theia/workspace": "1.5.0"
+ "@theia/callhierarchy": "1.6.0",
+ "@theia/console": "1.6.0",
+ "@theia/core": "1.6.0",
+ "@theia/debug": "1.6.0",
+ "@theia/editor": "1.6.0",
+ "@theia/editor-preview": "1.6.0",
+ "@theia/electron": "1.6.0",
+ "@theia/file-search": "1.6.0",
+ "@theia/filesystem": "1.6.0",
+ "@theia/getting-started": "1.6.0",
+ "@theia/git": "1.6.0",
+ "@theia/keymaps": "1.6.0",
+ "@theia/markers": "1.6.0",
+ "@theia/messages": "1.6.0",
+ "@theia/metrics": "1.6.0",
+ "@theia/mini-browser": "1.6.0",
+ "@theia/monaco": "1.6.0",
+ "@theia/navigator": "1.6.0",
+ "@theia/outline-view": "1.6.0",
+ "@theia/output": "1.6.0",
+ "@theia/plugin": "1.6.0",
+ "@theia/plugin-dev": "1.6.0",
+ "@theia/plugin-ext": "1.6.0",
+ "@theia/plugin-ext-vscode": "1.6.0",
+ "@theia/plugin-metrics": "1.6.0",
+ "@theia/preferences": "1.6.0",
+ "@theia/preview": "1.6.0",
+ "@theia/process": "1.6.0",
+ "@theia/scm": "1.6.0",
+ "@theia/scm-extra": "1.6.0",
+ "@theia/search-in-workspace": "1.6.0",
+ "@theia/task": "1.6.0",
+ "@theia/terminal": "1.6.0",
+ "@theia/timeline": "1.6.0",
+ "@theia/typehierarchy": "1.6.0",
+ "@theia/userstorage": "1.6.0",
+ "@theia/variable-resolver": "1.6.0",
+ "@theia/vsx-registry": "1.6.0",
+ "@theia/workspace": "1.6.0"
},
"devDependencies": {
- "@theia/cli": "1.5.0"
+ "@theia/cli": "1.6.0"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",