summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Carru2019-06-20 17:13:04 +0200
committerPierre Carru2019-06-20 17:29:37 +0200
commit48d675856c9f2f6f29cdc2fcd9e2cc329b7f9dbd (patch)
tree1fd97cd19651ce947c2b06aacdd535fa6d1fedf9
downloadaur-48d675856c9f2f6f29cdc2fcd9e2cc329b7f9dbd.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD53
-rw-r--r--package.json30
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec105a4c9100
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = theia-next
+ pkgver = 20190620
+ pkgrel = 1
+ url = https://www.theia-ide.org/
+ arch = any
+ license = EPL2
+ depends = nodejs
+ options = !strip
+ source = package.json
+ sha1sums = 1e84fc34576beac0d376c9970af1d2403a6c731f
+
+pkgname = theia-next
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..428be3bb2e1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Pierre Carru <aur at carru.fr>
+# based on https://github.com/theia-ide/theia-apps/blob/master/theia-docker/Dockerfile#L8
+# see also https://spectrum.chat/theia/general/how-to-package-the-browser-example-app~308c1998-2082-4063-ad99-0f1fd3b64d78
+
+pkgname=theia-next
+pkgver=20190620
+pkgrel=1
+arch=('any')
+url='https://www.theia-ide.org/'
+license=('EPL2')
+depends=(nodejs)
+makedepends=()
+
+#_ms_python_version=2019.5.18875
+#_ms_python_vsix="ms-python.python-${_ms_python_version}.vsix"
+
+source=(
+ "package.json"
+)
+#"${_ms_python_vsix}::https://github.com/microsoft/vscode-python/releases/download/${_ms_python_version}/ms-python-release.vsix"
+sha1sums=('1e84fc34576beac0d376c9970af1d2403a6c731f')
+#noextract=("${_ms_python_vsix}")
+options=(!strip)
+
+#prepare() {
+ #mkdir -p plugins
+ #mv ${_ms_python_vsix} plugins/
+#}
+
+build() {
+ mkdir -p node_modules
+
+ npx yarn
+ NODE_OPTIONS="--max_old_space_size=4096" npx yarn theia build
+
+ npx yarn --production --offline
+ npx yarn autoclean --init
+ echo *.ts >> .yarnclean
+ echo *.ts.map >> .yarnclean
+ echo *.spec.* >> .yarnclean
+ npx yarn autoclean --force
+}
+
+package() {
+ mkdir -p $pkgdir/opt/
+ cp -RL $PWD $pkgdir/opt/theia
+
+ rm $pkgdir/opt/theia/webpack.config.js
+ rm $pkgdir/opt/theia/yarn.lock
+ rm $pkgdir/opt/theia/.yarnclean
+ rm $pkgdir/opt/theia/package.json
+}
+
diff --git a/package.json b/package.json
new file mode 100644
index 000000000000..ab5f13764b5e
--- /dev/null
+++ b/package.json
@@ -0,0 +1,30 @@
+{
+ "private": true,
+ "dependencies": {
+ "@theia/callhierarchy": "next",
+ "@theia/editor-preview": "next",
+ "@theia/file-search": "next",
+ "@theia/getting-started": "next",
+ "@theia/git": "next",
+ "@theia/json": "next",
+ "@theia/markers": "next",
+ "@theia/merge-conflicts": "next",
+ "@theia/messages": "next",
+ "@theia/mini-browser": "next",
+ "@theia/navigator": "next",
+ "@theia/outline-view": "next",
+ "@theia/preferences": "next",
+ "@theia/preview": "next",
+ "@theia/search-in-workspace": "next",
+ "@theia/terminal": "next",
+ "@theia/textmate-grammars": "next",
+ "@theia/typescript": "next",
+ "@theia/tslint": "next",
+ "typescript": "latest",
+ "@theia/plugin-ext-vscode": "next"
+ },
+ "devDependencies": {
+ "@theia/cli": "next",
+ "@theia/debug": "next"
+ }
+}