summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Carru2019-06-20 18:03:35 +0200
committerPierre Carru2019-06-20 18:05:16 +0200
commit6bd6ba902294fef41beea8360f9e5924d9702e07 (patch)
treef78b3e3557f992f89e75d8551d48de25e1f884d5
parentdf75fa88cb99d8332fa40ced5b243d37ec04ec3e (diff)
downloadaur-6bd6ba902294fef41beea8360f9e5924d9702e07.tar.gz
go and python vscode extensions
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD33
-rwxr-xr-xtheia2
3 files changed, 32 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd8409113035..c21e7a44ae4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
pkgbase = theia-next
pkgver = 20190620
- pkgrel = 2
+ pkgrel = 3
url = https://www.theia-ide.org/
arch = any
license = EPL2
depends = nodejs
+ noextract = ms-python.python-2019.5.18875.vsix
options = !strip
+ source = theia
source = package.json
+ source = ms-python.python-2019.5.18875.vsix::https://github.com/microsoft/vscode-python/releases/download/2019.5.18875/ms-python-release.vsix
+ source = Go-0.11.0.vsix::https://github.com/microsoft/vscode-go/releases/download/0.11.0/Go-0.11.0.vsix
+ sha1sums = 1155980968a6c82fe8a77c29284761bb0de63785
sha1sums = 1e84fc34576beac0d376c9970af1d2403a6c731f
+ sha1sums = 2b0672378cbc96e5cfa778b19b8f0ae92f67686a
+ sha1sums = 5e8066e914792f8d2793e495ce386cd6b2df1afa
pkgname = theia-next
diff --git a/PKGBUILD b/PKGBUILD
index 15fabe97ec81..bb3ecf43a614 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,37 @@
pkgname=theia-next
pkgver=20190620
-pkgrel=2
+pkgrel=3
arch=('any')
url='https://www.theia-ide.org/'
license=('EPL2')
depends=(nodejs)
makedepends=()
-#_ms_python_version=2019.5.18875
-#_ms_python_vsix="ms-python.python-${_ms_python_version}.vsix"
+_ms_python_version=2019.5.18875
+_ms_python_vsix="ms-python.python-${_ms_python_version}.vsix"
+
+_ms_go_version=0.11.0
+_ms_go_vsix="Go-${_ms_go_version}.vsix"
source=(
+ "theia"
"package.json"
+ "${_ms_python_vsix}::https://github.com/microsoft/vscode-python/releases/download/${_ms_python_version}/ms-python-release.vsix"
+ "${_ms_go_vsix}::https://github.com/microsoft/vscode-go/releases/download/${_ms_go_version}/Go-${_ms_go_version}.vsix"
)
-#"${_ms_python_vsix}::https://github.com/microsoft/vscode-python/releases/download/${_ms_python_version}/ms-python-release.vsix"
-sha1sums=('1e84fc34576beac0d376c9970af1d2403a6c731f')
-#noextract=("${_ms_python_vsix}")
+sha1sums=('1155980968a6c82fe8a77c29284761bb0de63785'
+ '1e84fc34576beac0d376c9970af1d2403a6c731f'
+ '2b0672378cbc96e5cfa778b19b8f0ae92f67686a'
+ '5e8066e914792f8d2793e495ce386cd6b2df1afa')
+noextract=("${_ms_python_vsix}")
options=(!strip) #to speed up build
-#prepare() {
- #mkdir -p plugins
- #mv ${_ms_python_vsix} plugins/
-#}
+prepare() {
+ mkdir -p plugins
+ mv ${_ms_python_vsix} plugins/
+ mv ${_ms_go_vsix} plugins/
+}
build() {
mkdir -p node_modules
@@ -42,12 +51,14 @@ build() {
}
package() {
- mkdir -p $pkgdir/opt/
+ mkdir -p $pkgdir/opt/
cp -RL $PWD $pkgdir/opt/theia
rm $pkgdir/opt/theia/webpack.config.js
rm $pkgdir/opt/theia/yarn.lock
rm $pkgdir/opt/theia/.yarnclean
rm $pkgdir/opt/theia/package.json
+
+ install -Dm755 theia "$pkgdir/usr/bin/theia"
}
diff --git a/theia b/theia
new file mode 100755
index 000000000000..88c6d9156036
--- /dev/null
+++ b/theia
@@ -0,0 +1,2 @@
+#!/usr/bin/env bash
+exec node /opt/theia/src-gen/backend/main.js --plugins=local-dir:/opt/theia/plugins/ --hostname=127.0.0.1 "$@"