aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReto Brunner2018-12-26 08:52:35 +0100
committerReto Brunner2018-12-26 09:05:20 +0100
commit30f9025cf02240e7a744fa4d9048c29aec86037e (patch)
treeea24a9628a80b6f62d605601e9c2836821d9ce90
parentc4f5490709d9b025705f7fe346a034431111717f (diff)
downloadaur-30f9025cf02240e7a744fa4d9048c29aec86037e.tar.gz
Revert split config/data dirs
And address the other review comments
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--system.service4
-rw-r--r--tmpfiles.d3
4 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f47fee19d803..78777edfb729 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,16 +9,16 @@ pkgbase = thelounge
depends = nodejs
noextract = thelounge-2.7.1.tgz
backup = etc/thelounge/config.js
- source = http://registry.npmjs.org/thelounge/-/thelounge-2.7.1.tgz
+ source = https://registry.npmjs.org/thelounge/-/thelounge-2.7.1.tgz
source = system.service
source = user.service
source = sysusers.d
source = tmpfiles.d
- md5sums = f2be61e721cc677fb624687cf1e8944c
- md5sums = e52c5db8dece96c773718b402e4679ad
- md5sums = 7493ff3e6bb98daae42b26bf97173ed3
- md5sums = bf9da927d1432ec00a8dc0b7183745fc
- md5sums = 456c3d6d70aa33da967f79d215621dba
+ sha256sums = 4b4970caba850042244798008afd334dd2ddd7e25339c864837ce11ba4703021
+ sha256sums = c92210f6ac8f01c1cd01b6b26793094cd2feea583ed21fab3564d6bcafdc7a20
+ sha256sums = 055f7e05e9e2528474526ceea864502112e27024c89c997b26ddace86c24dbc6
+ sha256sums = 30fab63b8a4ffcfdda4c5b8d7c66822a323c4f1de6ca62b77fe9500f4befc0a5
+ sha256sums = 4060efc92346c7193e699ffe1b802d85dc45daa7b5260ecdf70a6b993c30b01a
pkgname = thelounge
diff --git a/PKGBUILD b/PKGBUILD
index 85a2036900f9..c255ed4ee9eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,25 +11,25 @@ depends=('nodejs')
makedepends=('npm')
backup=('etc/thelounge/config.js')
source=(
- "http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz"
+ "https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz"
'system.service'
'user.service'
'sysusers.d'
'tmpfiles.d'
)
noextract=("$pkgname-$pkgver.tgz")
-md5sums=('f2be61e721cc677fb624687cf1e8944c'
- 'e52c5db8dece96c773718b402e4679ad'
- '7493ff3e6bb98daae42b26bf97173ed3'
- 'bf9da927d1432ec00a8dc0b7183745fc'
- '456c3d6d70aa33da967f79d215621dba')
+sha256sums=('4b4970caba850042244798008afd334dd2ddd7e25339c864837ce11ba4703021'
+ 'c92210f6ac8f01c1cd01b6b26793094cd2feea583ed21fab3564d6bcafdc7a20'
+ '055f7e05e9e2528474526ceea864502112e27024c89c997b26ddace86c24dbc6'
+ '30fab63b8a4ffcfdda4c5b8d7c66822a323c4f1de6ca62b77fe9500f4befc0a5'
+ '4060efc92346c7193e699ffe1b802d85dc45daa7b5260ecdf70a6b993c30b01a')
package() {
export NODE_ENV=production
npm install -g --user root --prefix "$pkgdir/usr" "$pkgname-$pkgver.tgz" --cache "${srcdir}/npm-cache"
- echo /var/lib/thelounge > "$pkgdir/usr/lib/node_modules/$pkgname/.thelounge_home"
+ echo /etc/thelounge > "$pkgdir/usr/lib/node_modules/$pkgname/.thelounge_home"
# add default config
install -Dm 644 "$pkgdir/usr/lib/node_modules/$pkgname/defaults/config.js" "$pkgdir/etc/thelounge/config.js"
diff --git a/system.service b/system.service
index b311b2344a14..82017182aa95 100644
--- a/system.service
+++ b/system.service
@@ -6,10 +6,10 @@ After=network.target
User=thelounge
Group=thelounge
Type=simple
-Environment=THELOUNGE_HOME=/var/lib/thelounge
+Environment=THELOUNGE_HOME=/etc/thelounge
ExecStart=/usr/bin/thelounge start
ProtectSystem=strict
-ReadWritePaths=/etc/thelounge /var/lib/thelounge
+ReadWritePaths=/etc/thelounge
ProtectHome=yes
NoNewPrivileges=yes
PrivateTmp=yes
diff --git a/tmpfiles.d b/tmpfiles.d
index 061f13dc2e42..39bab2147da2 100644
--- a/tmpfiles.d
+++ b/tmpfiles.d
@@ -3,6 +3,3 @@ d /etc/thelounge 0755 thelounge thelounge
d /etc/thelounge/users 0755 thelounge thelounge
z "/etc/thelounge/users/*" 0640 thelounge thelounge
z /etc/thelounge/config.js - thelounge thelounge
-d /var/lib/thelounge 0755 thelounge thelounge
-L /var/lib/thelounge/users - thelounge thelounge - /etc/thelounge/users
-L /var/lib/thelounge/config.js - thelounge thelounge - /etc/thelounge/config.js