summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReto Brunner2024-01-28 12:38:22 +0100
committerReto Brunner2024-01-28 12:41:48 +0100
commit1b1e9d9d73d61779e06425b22f6f5001413c7fe2 (patch)
tree827ddfb4efe59f77e07037d445ef6dee52ea7cd6
parent95adce552d5ee66ddd8e4c416052730fac06e916 (diff)
downloadaur-1b1e9d9d73d61779e06425b22f6f5001413c7fe2.tar.gz
sqlite: adapt to switch to prebuild
https://github.com/TryGhost/node-sqlite3/commit/605c7f981abbcf980cb44f54abba285de9a69a23
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d888e3d20e73..31c88546fac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thelounge-git
pkgdesc = Modern self-hosted web IRC client
- pkgver = v4.4.0.pre.1.r0.g30a3ba48
+ pkgver = v4.4.1.r114.ga8be84028
pkgrel = 1
url = https://thelounge.chat/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 2b4902bf970b..a9ddfe33cd4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Reto Brunner <reto@labrat.space>
pkgname=thelounge-git
_realname=thelounge
-pkgver=v4.4.0.pre.1.r0.g30a3ba48
+pkgver=v4.4.1.r114.ga8be84028
pkgrel=1
pkgdesc='Modern self-hosted web IRC client'
url='https://thelounge.chat/'
@@ -26,18 +26,18 @@ sha256sums=('SKIP'
'c07fc7aaa91f6d2407d9ea2d15bfa780bfc06e3487efa138a9385307dcf9f41d')
pkgver() {
- cd $_realname
+ cd $_realname || exit 1
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
echo /etc/thelounge > "$_realname/.thelounge_home"
- cd $_realname
+ cd $_realname || exit 1
yarn install --frozen-lockfile --non-interactive --ignore-scripts --cache-folder "$srcdir/yarn-cache"
}
build() {
- cd $_realname
+ cd $_realname || exit 1
export NODE_ENV=production
yarn build
mkdir _build
@@ -45,7 +45,7 @@ build() {
# ensure we get the lockfile that we expect and fetch the deps
cp package.json yarn.lock _build
- cd _build
+ cd _build || exit 1
# Install the package itself
# we on purpose don't use yarn global add, because --ignore-scripts
@@ -53,11 +53,11 @@ build() {
yarn add --no-default-rc --frozen-lockfile \
--prod --non-interactive --ignore-scripts \
--cache-folder "$srcdir/yarn-cache" --offline \
- file:"$(readlink -e ./$tarball)"
+ file:"$(readlink -e "./$tarball")"
# build sqlite3 from source, avoids the binary blob (kinda)
- cd node_modules/sqlite3
- ./node_modules/.bin/node-pre-gyp rebuild
+ cd node_modules/sqlite3 || exit 1
+ yarn --no-default-rc --frozen-lockfile --non-interactive run rebuild
}