summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-16 03:22:45 +0100
committeractionless2020-03-16 03:22:45 +0100
commit26138f4bf9ba3f2d710247a82f00ed474bdd4747 (patch)
treef57ee66d64d6a8ea6b680851060bd3f3338f0387
downloadaur-26138f4bf9ba3f2d710247a82f00ed474bdd4747.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD45
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae81f9b5a9a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = themix-gui-git
+ pkgdesc = Plugin-based theme designer GUI for environments (like GTK2, GTK3, Cinnamon, GNOME, MATE, Openbox, Xfwm), icons, and terminal palettes.
+ pkgver = 1.12.6.r6.g264a6533
+ pkgrel = 1
+ url = https://github.com/themix-project/oomox
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ depends = python-gobject
+ optdepends = xorg-xrdb: for the `xresources` theme
+ optdepends = themix-theme-oomox: Theme Style plugin
+ provides = themix-gui
+ conflicts = themix-gui
+ source = git+https://github.com/themix-project/oomox.git#branch=master
+ md5sums = SKIP
+
+pkgname = themix-gui-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..496740ceea8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+
+oomox/
+themix-gui-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12ca309f043f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+# Upstream URL: https://github.com/themix-project/oomox
+
+pkgname=themix-gui-git
+pkgver=1.12.6.r7.g7bd6e2fd
+pkgrel=1
+pkgdesc="Plugin-based theme designer GUI for
+ environments (like GTK2, GTK3, Cinnamon, GNOME, MATE, Openbox, Xfwm),
+ icons, and terminal palettes."
+arch=('x86_64' 'i686')
+url="https://github.com/themix-project/oomox"
+license=('GPL3')
+source=(
+ "git+https://github.com/themix-project/oomox.git#branch=master"
+)
+md5sums=('SKIP')
+depends=(
+ 'gtk3'
+ 'python-gobject'
+)
+makedepends=(
+ 'git'
+)
+optdepends=(
+ 'xorg-xrdb: for the `xresources` theme'
+ 'themix-theme-oomox: Theme Style plugin'
+)
+provides=('themix-gui')
+conflicts=('themix-gui')
+
+pkgver() {
+ cd "${srcdir}/oomox"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _oomox_dir=/opt/oomox
+ _oomox_gui_dir=${_oomox_dir}/oomox_gui
+
+ cd "${srcdir}/oomox"
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_gui
+ python -O -m compileall ${pkgdir}${_oomox_gui_dir} -d ${_oomox_gui_dir}
+}
+
+# vim: ft=PKGBUILD