summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-17 17:43:03 +0100
committeractionless2020-03-17 17:43:03 +0100
commit3ffb9e48b2a02109b9b6bbcaf4026b43e5a07ceb (patch)
tree38dd9e3e6fc26c61faa5b1e21f27eb3759ff9913
parentc9a78cd804da3c5cd20e0f057e138cdf4b862b81 (diff)
downloadaur-3ffb9e48b2a02109b9b6bbcaf4026b43e5a07ceb.tar.gz
add new optional dep, fix missing 'import random' plugin
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fe4dc8bf529..29c546de70fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = themix-gui-git
pkgdesc = Plugin-based theme designer GUI for environments (like GTK2, GTK3, Cinnamon, GNOME, MATE, Openbox, Xfwm), icons and terminal palettes.
- pkgver = 1.12.6.r11.gf461833e
+ pkgver = 1.12.6.r14.ge495c2c3
pkgrel = 1
url = https://github.com/themix-project/oomox
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = themix-gui-git
depends = gtk3
depends = python-gobject
optdepends = themix-icons-gnome-colors: Icons Style plugin
+ optdepends = themix-import-images: Import palettes from images
optdepends = themix-theme-materia: Theme Style plugin
optdepends = themix-theme-oomox: Theme Style plugin
optdepends = xorg-xrdb: for the `xresources` theme
diff --git a/PKGBUILD b/PKGBUILD
index 5874ae91c61c..1a2100245165 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Upstream URL: https://github.com/themix-project/oomox
pkgname=themix-gui-git
-pkgver=1.12.6.r11.gf461833e
+pkgver=1.12.6.r14.ge495c2c3
pkgrel=1
pkgdesc="Plugin-based theme designer GUI for
environments (like GTK2, GTK3, Cinnamon, GNOME, MATE, Openbox, Xfwm),
@@ -23,6 +23,7 @@ makedepends=(
)
optdepends=(
'themix-icons-gnome-colors: Icons Style plugin'
+ 'themix-import-images: Import palettes from images'
'themix-theme-materia: Theme Style plugin'
'themix-theme-oomox: Theme Style plugin'
'xorg-xrdb: for the `xresources` theme'
@@ -40,7 +41,7 @@ package() {
_oomox_gui_dir=${_oomox_dir}/oomox_gui
cd "${srcdir}/oomox"
- make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_gui
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_gui install_import_random
python -O -m compileall ${pkgdir}${_oomox_gui_dir} -d ${_oomox_gui_dir}
}