summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-17 18:44:33 +0100
committeractionless2020-03-17 18:44:33 +0100
commita17ec6bfc8fa4102be21d0fbc8c45beb8c3cc1bd (patch)
tree56b0f7de9c1d86883f83bd1d61983bde060fd101
parent3ffb9e48b2a02109b9b6bbcaf4026b43e5a07ceb (diff)
downloadaur-a17ec6bfc8fa4102be21d0fbc8c45beb8c3cc1bd.tar.gz
add new optional deps, remove unnecessary fix for missing 'import random' plugin
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29c546de70fe..958499cfbe70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = themix-gui-git
pkgdesc = Plugin-based theme designer GUI for environments (like GTK2, GTK3, Cinnamon, GNOME, MATE, Openbox, Xfwm), icons and terminal palettes.
- pkgver = 1.12.6.r14.ge495c2c3
+ pkgver = 1.12.6.r17.gc9fc5258
pkgrel = 1
url = https://github.com/themix-project/oomox
arch = x86_64
@@ -9,8 +9,10 @@ pkgbase = themix-gui-git
makedepends = git
depends = gtk3
depends = python-gobject
+ optdepends = themix-export-spotify: Apply theme to Spotify
optdepends = themix-icons-gnome-colors: Icons Style plugin
optdepends = themix-import-images: Import palettes from images
+ optdepends = themix-plugin-base16: Import and export from Base16 project format
optdepends = themix-theme-materia: Theme Style plugin
optdepends = themix-theme-oomox: Theme Style plugin
optdepends = xorg-xrdb: for the `xresources` theme
diff --git a/PKGBUILD b/PKGBUILD
index 1a2100245165..c844f319078f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Upstream URL: https://github.com/themix-project/oomox
pkgname=themix-gui-git
-pkgver=1.12.6.r14.ge495c2c3
+pkgver=1.12.6.r17.gc9fc5258
pkgrel=1
pkgdesc="Plugin-based theme designer GUI for
environments (like GTK2, GTK3, Cinnamon, GNOME, MATE, Openbox, Xfwm),
@@ -22,8 +22,10 @@ makedepends=(
'git'
)
optdepends=(
+ 'themix-export-spotify: Apply theme to Spotify'
'themix-icons-gnome-colors: Icons Style plugin'
'themix-import-images: Import palettes from images'
+ 'themix-plugin-base16: Import and export from Base16 project format'
'themix-theme-materia: Theme Style plugin'
'themix-theme-oomox: Theme Style plugin'
'xorg-xrdb: for the `xresources` theme'
@@ -41,7 +43,7 @@ package() {
_oomox_gui_dir=${_oomox_dir}/oomox_gui
cd "${srcdir}/oomox"
- make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_gui install_import_random
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_gui
python -O -m compileall ${pkgdir}${_oomox_gui_dir} -d ${_oomox_gui_dir}
}