summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-17 19:30:18 +0100
committeractionless2020-03-17 19:30:18 +0100
commitc7721bd0ddb58cce4e4397d9b1d9fb2c2820a216 (patch)
treec40932db34e80bc58e9338a0aafe0ab7a2e1e127
downloadaur-c7721bd0ddb58cce4e4397d9b1d9fb2c2820a216.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD64
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93e235818728
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = themix-icons-archdroid-git
+ pkgdesc = Archdroid icons plugin for Themix GUI designer
+ pkgver = 1.0.2.r1.g775b8c2c0
+ pkgrel = 1
+ url = https://github.com/themix-project/archdroid-icon-theme
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = python
+ depends = sed
+ optdepends = themix-gui: GUI
+ optdepends = breeze-icons: fallback icons
+ optdepends = gnome-icon-theme: fallback icons
+ optdepends = gnome-icon-theme-symbolic: fallback icons
+ optdepends = oxygen-icons: fallback icons
+ provides = themix-icons-archdroid
+ conflicts = themix-icons-archdroid
+ options = !strip
+ source = git+https://github.com/themix-project/oomox.git#branch=master
+ source = archdroid-icon-theme::git+https://github.com/themix-project/archdroid-icon-theme.git#branch=master
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = themix-icons-archdroid-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccfcaa2b617e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+
+oomox/
+archdroid-icon-theme/
+themix-icons-archdroid-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cc51421c20f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+# Upstream URL: https://github.com/themix-project/archdroid-icon-theme
+
+_pkgname=themix-icons-archdroid
+_reponame=archdroid-icon-theme
+pkgname="${_pkgname}-git"
+pkgver=1.0.2.r1.g775b8c2c0
+pkgrel=1
+pkgdesc="Archdroid icons plugin for Themix GUI designer"
+arch=('x86_64' 'i686')
+url="https://github.com/themix-project/${_reponame}"
+license=('GPL3')
+source=(
+ "git+https://github.com/themix-project/oomox.git#branch=master"
+ "${_reponame}::git+https://github.com/themix-project/${_reponame}.git#branch=master"
+)
+md5sums=('SKIP'
+ 'SKIP')
+depends=(
+ 'sed'
+)
+makedepends=(
+ 'git'
+ 'python'
+)
+optdepends=(
+ 'themix-gui: GUI'
+ 'breeze-icons: fallback icons'
+ 'gnome-icon-theme: fallback icons'
+ 'gnome-icon-theme-symbolic: fallback icons'
+ 'oxygen-icons: fallback icons'
+)
+options=(
+ '!strip'
+)
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _oomox_dir=/opt/oomox
+
+ _oomox_dir=/opt/oomox
+ _plugin_name=icons_archdroid
+ _plugin_subpath="/${_reponame}"
+
+ pkg_tmp_dir="${pkgdir}/_tmp"
+ rm -fr "$pkg_tmp_dir"
+ cp -r "${srcdir}/oomox" "$pkg_tmp_dir"
+ rm -rf "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+ cp -r "${srcdir}/${_reponame}" "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+
+ cd "$pkg_tmp_dir"
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" "install_${_plugin_name}"
+ rm -fr "$pkg_tmp_dir"
+
+ python -O -m compileall "${pkgdir}${_oomox_dir}/plugins/${_plugin_name}" -d "${_oomox_dir}/plugins/${_plugin_name}"
+}
+
+# vim: ft=PKGBUILD