summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-17 20:23:21 +0100
committeractionless2020-03-17 20:23:42 +0100
commit343f3d6dbafa21e47ba06dd180528923dac2eada (patch)
tree9d00a30eb5d66c5466f18aa30e3b9459ee4416ee
downloadaur-343f3d6dbafa21e47ba06dd180528923dac2eada.tar.gz
fix pkgver
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD59
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..693000c93649
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = themix-icons-suru-plus-aspromauros-git
+ pkgdesc = Suru++ Aspromauros icons plugin for Themix GUI designer
+ pkgver = 3.0.r0.gd43a8ec4
+ pkgrel = 1
+ url = https://github.com/gusbemacbe/suru-plus-aspromauros/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = python
+ depends = sed
+ depends = findutils
+ optdepends = themix-gui: GUI
+ provides = themix-icons-suru-plus-aspromauros
+ conflicts = themix-icons-suru-plus-aspromauros
+ options = !strip
+ source = git+https://github.com/themix-project/oomox.git#branch=master
+ source = suru-plus-aspromauros::git+https://github.com/gusbemacbe/suru-plus-aspromauros.git#branch=master
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = themix-icons-suru-plus-aspromauros-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..834e7bae5889
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+
+oomox/
+suru-plus-aspromauros/
+themix-icons-suru-plus-aspromauros-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..917585ab78ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+# Upstream URL: https://github.com/gusbemacbe/suru-plus-aspromauros/
+
+_pkgname=themix-icons-suru-plus-aspromauros
+_reponame=suru-plus-aspromauros
+pkgname="${_pkgname}-git"
+pkgver=3.0.r0.gd43a8ec4
+pkgrel=1
+pkgdesc="Suru++ Aspromauros icons plugin for Themix GUI designer"
+arch=('x86_64' 'i686')
+url="https://github.com/gusbemacbe/suru-plus-aspromauros/"
+license=('GPL3')
+source=(
+ "git+https://github.com/themix-project/oomox.git#branch=master"
+ "${_reponame}::git+https://github.com/gusbemacbe/suru-plus-aspromauros.git#branch=master"
+)
+md5sums=('SKIP'
+ 'SKIP')
+depends=(
+ 'sed'
+ 'findutils'
+)
+makedepends=(
+ 'git'
+ 'python'
+)
+optdepends=(
+ 'themix-gui: GUI'
+)
+options=(
+ '!strip'
+)
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+package() {
+ _oomox_dir=/opt/oomox
+ _plugin_name=icons_suruplus_aspromauros
+ _plugin_subpath="/${_reponame}"
+
+ pkg_tmp_dir="${pkgdir}/_tmp"
+ rm -fr "$pkg_tmp_dir"
+ cp -r "${srcdir}/oomox" "$pkg_tmp_dir"
+ rm -rf "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+ cp -r "${srcdir}/${_reponame}" "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+
+ cd "$pkg_tmp_dir"
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" "install_${_plugin_name}"
+ rm -fr "$pkg_tmp_dir"
+
+ python -O -m compileall "${pkgdir}${_oomox_dir}/plugins/${_plugin_name}" -d "${_oomox_dir}/plugins/${_plugin_name}"
+}
+
+# vim: ft=PKGBUILD