summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-17 17:35:43 +0100
committeractionless2020-03-17 17:35:43 +0100
commitf2af7b85707e002bee9bb5eb0eb4fab57e1a4c47 (patch)
tree09448692dc92cf2cae99bda7a6f11dc5cd88ee48
downloadaur-f2af7b85707e002bee9bb5eb0eb4fab57e1a4c47.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD44
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b72754af4d6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = themix-import-images-git
+ pkgdesc = Import plugin for Themix GUI designer to get color palettes from the images
+ pkgver = 1.12.6.r14.ge495c2c3
+ pkgrel = 1
+ url = https://github.com/themix-project/oomox
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ depends = python-gobject
+ optdepends = colorz: additional image analyzer
+ optdepends = python-colorthief: additional image analyzer
+ optdepends = python-haishoku: additional image analyzer
+ provides = themix-gui
+ conflicts = themix-gui
+ source = git+https://github.com/themix-project/oomox.git#branch=master
+ md5sums = SKIP
+
+pkgname = themix-import-images-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cab337abb44c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+
+oomox/
+themix-import-images-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1eddd17b3c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+# Upstream URL: https://github.com/themix-project/oomox
+
+pkgname=themix-import-images-git
+pkgver=1.12.6.r14.ge495c2c3
+pkgrel=1
+pkgdesc="Import plugin for Themix GUI designer to get color palettes from the images"
+arch=('x86_64' 'i686')
+url="https://github.com/themix-project/oomox"
+license=('GPL3')
+source=(
+ "git+https://github.com/themix-project/oomox.git#branch=master"
+)
+md5sums=('SKIP')
+depends=(
+ 'gtk3'
+ 'python-gobject'
+)
+makedepends=(
+ 'git'
+)
+optdepends=(
+ 'colorz: additional image analyzer'
+ 'python-colorthief: additional image analyzer'
+ 'python-haishoku: additional image analyzer'
+)
+provides=('themix-gui')
+conflicts=('themix-gui')
+
+pkgver() {
+ cd "${srcdir}/oomox"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _oomox_dir=/opt/oomox
+ _plugin_name=import_pil
+
+ cd "${srcdir}/oomox"
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_import_images
+ python -O -m compileall "${pkgdir}${_oomox_dir}/plugins/${_plugin_name}" -d "${_oomox_dir}/plugins/${_plugin_name}"
+}
+
+# vim: ft=PKGBUILD