summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-17 18:13:41 +0100
committeractionless2020-03-17 18:13:41 +0100
commitd1d429c5642de9ea4a41b47b6a93044e75130c49 (patch)
tree819890f4748e66a23ecfa9576c95766c1bdaf7c5
downloadaur-d1d429c5642de9ea4a41b47b6a93044e75130c49.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c6a5d8ce0c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = themix-plugin-base16-git
+ pkgdesc = Import and export plugin for Themix GUI designer to get color palettes from Base16 project
+ pkgver = 1.0.r6.g6ec2a41
+ pkgrel = 1
+ url = https://github.com/themix-project/themix-plugin-base16
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ depends = themix-gui
+ depends = python-pystache
+ depends = python-yaml
+ optdepends = themix-gui: GUI
+ provides = themix-plugin-base16
+ conflicts = themix-plugin-base16
+ options = !strip
+ source = themix-plugin-base16::git+https://github.com/themix-project/themix-plugin-base16.git#branch=master
+ md5sums = SKIP
+
+pkgname = themix-plugin-base16-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f507229b13e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+
+themix-plugin-base16/
+themix-plugin-base16-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73a527f64d11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+# Upstream URL: https://github.com/themix-project/themix-plugin-base16
+
+_pkgname=themix-plugin-base16
+_reponame=$_pkgname
+pkgname="${_pkgname}-git"
+pkgver=1.0.r6.g6ec2a41
+pkgrel=1
+pkgdesc="Import and export plugin for Themix GUI designer to get color palettes from Base16 project"
+arch=('x86_64' 'i686')
+url="https://github.com/themix-project/${_reponame}"
+license=('GPL3')
+source=(
+ "${_reponame}::git+https://github.com/themix-project/${_reponame}.git#branch=master"
+)
+md5sums=('SKIP')
+depends=(
+ 'themix-gui'
+ 'python-pystache'
+ 'python-yaml'
+)
+makedepends=(
+ 'git'
+)
+optdepends=(
+ 'themix-gui: GUI'
+)
+options=(
+ '!strip'
+)
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _oomox_dir=/opt/oomox
+ _plugin_name=base16
+
+ cd "${srcdir}/${_reponame}"
+ make -f Makefile_oomox_plugin DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install
+ python -O -m compileall "${pkgdir}${_oomox_dir}/plugins/${_plugin_name}" -d "${_oomox_dir}/plugins/${_plugin_name}"
+}
+
+# vim: ft=PKGBUILD