summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-16 05:45:14 +0100
committeractionless2020-03-16 05:45:14 +0100
commit6e4e472b5c168a6aac22accd9301072678a283d1 (patch)
tree82411f09be6f0cc979e54ec059dd670619df5ea1
downloadaur-6e4e472b5c168a6aac22accd9301072678a283d1.tar.gz
initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD78
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b20550eb6970
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = themix-theme-materia-git
+ pkgdesc = Materia theme plugin (GTK2, GTK3, Cinnamon, GNOME, Metacity, Unity, Xfwm) for Themix GUI designer. Have a hack for HiDPI in GTK2.
+ pkgver = v20191017.r149.gb6ccc2a9
+ pkgrel = 1
+ url = https://github.com/themix-project/oomox-gtk-theme
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = python
+ depends = gtk3
+ depends = glib2
+ depends = gdk-pixbuf2
+ depends = gtk-engine-murrine
+ depends = gtk-engines
+ depends = gnome-themes-extra
+ depends = sassc
+ depends = sed
+ depends = findutils
+ depends = grep
+ depends = bc
+ depends = parallel
+ depends = optipng
+ depends = resvg
+ optdepends = themix-gui: GUI
+ provides = themix-theme-materia
+ conflicts = themix-theme-materia
+ options = !strip
+ source = git+https://github.com/themix-project/oomox.git#branch=master
+ source = materia-theme::git+https://github.com/nana-4/materia-theme.git#branch=master
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = themix-theme-materia-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..42dc0c8eaa0c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+
+oomox/
+materia-theme/
+themix-theme-materia-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21deb1910533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+# Upstream URL: https://github.com/nana-4/materia-theme/
+
+_pkgname=themix-theme-materia
+_reponame=materia-theme
+pkgname="${_pkgname}-git"
+pkgver=v20191017.r149.gb6ccc2a9
+pkgrel=1
+pkgdesc="Materia theme plugin
+ (GTK2, GTK3, Cinnamon, GNOME, Metacity, Unity, Xfwm) for Themix GUI designer.
+ Have a hack for HiDPI in GTK2."
+arch=('x86_64' 'i686')
+url="https://github.com/themix-project/oomox-gtk-theme"
+license=('GPL3')
+source=(
+ "git+https://github.com/themix-project/oomox.git#branch=master"
+ "${_reponame}::git+https://github.com/nana-4/materia-theme.git#branch=master"
+)
+md5sums=(
+ "SKIP"
+ "SKIP"
+)
+depends=(
+ 'gtk3'
+ 'glib2'
+ 'gdk-pixbuf2'
+ 'gtk-engine-murrine'
+ 'gtk-engines'
+ 'gnome-themes-extra'
+ 'sassc'
+ 'sed'
+ 'findutils'
+ 'grep'
+ 'bc'
+ 'parallel'
+ 'optipng'
+
+ 'resvg'
+ ## or
+ #'inkscape'
+)
+makedepends=(
+ 'git'
+ 'python'
+)
+optdepends=(
+ 'themix-gui: GUI'
+)
+options=(
+ '!strip'
+)
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _oomox_dir=/opt/oomox
+ _plugin_name=theme_materia
+ _plugin_subpath="/${_reponame}"
+
+ pkg_tmp_dir="${pkgdir}/_tmp"
+ rm -fr "$pkg_tmp_dir"
+ cp -r "${srcdir}/oomox" "$pkg_tmp_dir"
+ rm -rf "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+ cp -r "${srcdir}/${_reponame}" "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+
+ cd "$pkg_tmp_dir"
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" "install_${_plugin_name}"
+ rm -fr "$pkg_tmp_dir"
+
+ python -O -m compileall "${pkgdir}${_oomox_dir}/plugins/${_plugin_name}" -d "${_oomox_dir}/plugins/${_plugin_name}"
+}
+
+# vim: ft=PKGBUILD