summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2020-05-02 23:30:40 +0200
committerEmmanuel Gil Peyrot2020-05-02 23:30:40 +0200
commita46e96efcd62f0a78ba3dfef5940361d679fee75 (patch)
treeb108b02efae60f4be5d0f232f81645386cd8b80a
downloadaur-a46e96efcd62f0a78ba3dfef5940361d679fee75.tar.gz
Hello world!
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--meson.patch57
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12c840f2d06d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = theoraplay-hg
+ pkgdesc = library used by games to play Theora videos
+ pkgver = 67
+ pkgrel = 1
+ url = https://icculus.org/theoraplay/
+ arch = x86_64
+ license = custom:zlib
+ makedepends = mercurial
+ provides = theoraplay
+ conflicts = theoraplay
+ source = hg+https://hg.icculus.org/icculus/theoraplay
+ source = meson.patch
+ md5sums = SKIP
+ md5sums = c9626328d164758e6cf487d2631c6864
+
+pkgname = theoraplay-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58946324691a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgname=theoraplay-hg
+pkgver=67
+pkgrel=1
+pkgdesc='library used by games to play Theora videos'
+arch=('x86_64')
+url='https://icculus.org/theoraplay/'
+license=('custom:zlib')
+makedepends=('mercurial')
+provides=('theoraplay')
+conflicts=('theoraplay')
+
+source=("hg+https://hg.icculus.org/icculus/theoraplay"
+ 'meson.patch')
+md5sums=('SKIP'
+ 'c9626328d164758e6cf487d2631c6864')
+
+pkgver() {
+ cd theoraplay
+ hg identify -n
+}
+
+prepare() {
+ cd theoraplay
+ hg patch ../meson.patch
+ meson --prefix=/usr --buildtype=release build
+}
+
+build() {
+ cd theoraplay/build
+ ninja
+}
+
+package() {
+ cd theoraplay/build
+ DESTDIR="$pkgdir" ninja install
+}
+
+# vim:set ts=2 sts=2 sw=2 et:
diff --git a/meson.patch b/meson.patch
new file mode 100644
index 000000000000..b6cde080a48d
--- /dev/null
+++ b/meson.patch
@@ -0,0 +1,57 @@
+# HG changeset patch
+# User Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Date 1588454589 -7200
+# Sat May 02 23:23:09 2020 +0200
+# Node ID 3cb38dfd6015cc4d9f3b7a9de2e5b85626bc3419
+# Parent 99e5fc74603e70d99e8b189eb58d02496f9a0457
+Add a meson build system.
+
+diff --git a/meson.build b/meson.build
+new file mode 100644
+--- /dev/null
++++ b/meson.build
+@@ -0,0 +1,44 @@
++project(
++ 'theoraplay',
++ 'c',
++ default_options: [
++ 'warning_level=3',
++ ],
++ meson_version: '>= 0.54',
++ license: 'Zlib',
++)
++
++sources = [
++ 'theoraplay.c',
++ 'theoraplay.h',
++ 'theoraplay_cvtrgb.h',
++]
++
++dependencies = [
++ dependency('ogg'),
++ dependency('vorbis'),
++ dependency('theoradec'),
++ dependency('threads'),
++]
++
++theoraplay = shared_library(
++ 'theoraplay',
++ sources,
++ dependencies: dependencies,
++ install: true,
++)
++
++pkgconfig = import('pkgconfig')
++
++pkgconfig.generate(
++ theoraplay,
++ name: 'theoraplay',
++ version: '0.1',
++ description: 'Multithreaded Ogg Theora/Ogg Vorbis decoding library',
++ subdirs: 'theoraplay',
++)
++
++install_headers(
++ 'theoraplay.h',
++ subdir: 'theoraplay',
++)