summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2016-03-01 21:05:47 +1100
committerVictor Tran2016-03-01 21:05:47 +1100
commitdf735123ea91e14125aed24c0332d175c71f666f (patch)
treebcd92b361d889aeae0cb829cfd56a856c0dd9e1d
downloadaur-df735123ea91e14125aed24c0332d175c71f666f.tar.gz
Initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..604a3b4ef7c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = thepackage
+ pkgdesc = Package Manager for theOS
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/thepackage
+ arch = x86_64
+ license = GPL2
+ makedepends = qtchooser
+ makedepends = git
+ depends = qt5-base
+ depends = xdg-utils
+ source = thepackage-1.0::git+https://github.com/vicr123/thepackage#branch=master
+ md5sums = SKIP
+
+pkgname = thepackage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14b9928d9773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=thepackage
+pkgver=1.0
+pkgrel=0
+pkgdesc="Package Manager for theOS"
+arch=("x86_64")
+url="https://github.com/vicr123/thepackage"
+license=('GPL2')
+depends=('qt5-base' 'xdg-utils')
+makedepends=('qtchooser' 'git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/thepackage#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/thepackage" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/thePackage.desktop" "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/thePackageUpdate.desktop" "$pkgdir/usr/share/applications"
+}