summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2021-02-10 22:55:05 +1100
committerVictor Tran2021-02-10 22:55:05 +1100
commit362bc06ceacdfff0d6534da622a48783be7598d2 (patch)
tree23af6d410a8794e5380f3d8f28222da9cbefbb02
downloadaur-362bc06ceacdfff0d6534da622a48783be7598d2.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..665de8fc6e25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = thepage
+ pkgdesc = Document Viewer using poppler
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/thepage
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-tools
+ depends = xdg-utils
+ depends = qt5-base
+ depends = the-libs
+ depends = qt5-svg
+ depends = poppler-qt5
+ source = thepage-1.0::https://github.com/vicr123/thepage/archive/v1.0.tar.gz
+ sha256sums = 6ec74fe265cbb864d51dada54056053235646a7a69437ddbb037bdc624abfef5
+
+pkgname = thepage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a03599a8f59f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=thepage
+pkgver=1.0
+pkgrel=0
+pkgdesc="Document Viewer using poppler"
+arch=("x86_64")
+url="https://github.com/vicr123/thepage"
+license=('GPL3')
+depends=('xdg-utils' 'qt5-base' 'the-libs' 'qt5-svg' 'poppler-qt5')
+makedepends=('git' 'qt5-tools')
+source=("$pkgname-$pkgver"::"https://github.com/vicr123/thepage/archive/v1.0.tar.gz")
+sha256sums=('6ec74fe265cbb864d51dada54056053235646a7a69437ddbb037bdc624abfef5')
+
+build() {
+ cd "thePage-$pkgver"
+ mkdir -p build
+ cd build
+ qmake ../thePage.pro
+ make
+}
+
+package() {
+ cd "thePage-$pkgver"
+ cd build
+ make install INSTALL_ROOT=$pkgdir
+}