summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetrito2017-04-11 11:23:45 +0200
committerdetrito2017-04-11 11:23:45 +0200
commit2ac5becfca289046de46374237d252cb34ee24d3 (patch)
tree0de02229800c7d446d4e2c766583b2a63aed4a89
parent3063d56e79c8d83e5b2042506f1a7baa49843d62 (diff)
downloadaur-2ac5becfca289046de46374237d252cb34ee24d3.tar.gz
Therion 5.4.0
-rw-r--r--.SRCINFO20
-rwxr-xr-x[-rw-r--r--]PKGBUILD50
-rw-r--r--loch_vtk7.patch (renamed from loch-makefile-vtk-6.1.patch)16
-rw-r--r--make_install.patch (renamed from makefile-install-path.patch)20
-rw-r--r--therion_ini.patch (renamed from therion-ini.patch)10
5 files changed, 59 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 738f32eb728a..c466f7ead677 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Dec 29 01:35:10 UTC 2015
pkgbase = therion
pkgdesc = A cave surveying software
- pkgver = 5.3.16
+ pkgver = 5.4.0
pkgrel = 1
url = http://therion.speleo.sk
arch = x86_64
@@ -19,14 +17,14 @@ pkgbase = therion
optdepends = libjpeg-turbo
optdepends = libpng
optdepends = zlib
- source = http://therion.speleo.sk/downloads/therion-5.3.16.tar.gz
- source = loch-makefile-vtk-6.1.patch
- source = makefile-install-path.patch
- source = therion-ini.patch
- sha256sums = 73cda5225725d3e8cadd6fada9e506ab94b093d4e7a9fc90eaf23f8c7be6eb85
- sha256sums = d737140a4174d5b6cb55095a84010667e6bcbc2a645a1758229a422dd9daa742
- sha256sums = 9944238d0ade161143b04446b98f1627f2a20e33f29c8f9135f5d051e5af2c1e
- sha256sums = 85129bd20f12349fc7da91b262148c6c58265982fe07322b6f89cdb75e4bb5cd
+ source = http://github.com/therion/therion/archive/v5.4.0.tar.gz
+ source = loch_vtk7.patch
+ source = make_install.patch
+ source = therion_ini.patch
+ sha256sums = 0d505093fedfc0a3cfda865407067d19c1aca9e6d1823b4007d373f6e14e48cd
+ sha256sums = 81cd6c75a74897831edd4116bb97c71090023abbb14725b96d2a219f67cb5613
+ sha256sums = bf3fda048fb1a4f4c49f0daf7faa7e40c630748b33ed27c47bcfabba4014571c
+ sha256sums = 0639b0c4c9660af33675bf948ca4678d441167f77f7818cc015b7738a53fb8f3
pkgname = therion
diff --git a/PKGBUILD b/PKGBUILD
index c0072317d693..0423983ec2f1 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,48 @@
# Maintainer: detrito <detrito@inventati.org>
pkgname=therion
-pkgver=5.3.16
+pkgver=5.4.0
pkgrel=1
pkgdesc="A cave surveying software"
arch=('x86_64' 'i686')
url="http://therion.speleo.sk"
license=('GPL2')
-depends=('tk' 'bwidget' 'texlive-core' 'imagemagick' 'wxgtk' 'glu'
- 'vtk' 'webkitgtk2')
+# avoid parallel-execution errors
+MAKEFLAGS="-j1"
+
+depends=('tk' 'bwidget' 'texlive-core' 'imagemagick' 'wxgtk' 'glu' 'vtk'
+ 'webkitgtk2')
optdepends=('libjpeg-turbo' 'libpng' 'zlib')
-source=("${url}/downloads/${pkgname}-${pkgver}.tar.gz"
- "loch-makefile-vtk-6.1.patch"
- "makefile-install-path.patch"
- "therion-ini.patch")
-sha256sums=('73cda5225725d3e8cadd6fada9e506ab94b093d4e7a9fc90eaf23f8c7be6eb85'
- 'd737140a4174d5b6cb55095a84010667e6bcbc2a645a1758229a422dd9daa742'
- '9944238d0ade161143b04446b98f1627f2a20e33f29c8f9135f5d051e5af2c1e'
- '85129bd20f12349fc7da91b262148c6c58265982fe07322b6f89cdb75e4bb5cd')
+source=("http://github.com/therion/therion/archive/v${pkgver}.tar.gz"
+ "loch_vtk7.patch"
+ "make_install.patch"
+ "therion_ini.patch")
+
+sha256sums=('0d505093fedfc0a3cfda865407067d19c1aca9e6d1823b4007d373f6e14e48cd'
+ '81cd6c75a74897831edd4116bb97c71090023abbb14725b96d2a219f67cb5613'
+ 'bf3fda048fb1a4f4c49f0daf7faa7e40c630748b33ed27c47bcfabba4014571c'
+ '0639b0c4c9660af33675bf948ca4678d441167f77f7818cc015b7738a53fb8f3'
+ )
build() {
- # patch to compile loch with VTK 6.1
- cd "${srcdir}/${pkgname}/loch"
- patch -p0 -i ${srcdir}/loch-makefile-vtk-6.1.patch
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # patch to compile loch with VTK 7.1
+ patch -p0 -i ${srcdir}/loch_vtk7.patch
+
# patch to install in $pkgdir
- cd ${srcdir}/${pkgname}
- patch -p0 -i ${srcdir}/makefile-install-path.patch
-
- # patch config file
- patch -p0 -i ${srcdir}/therion-ini.patch
-
-make
+ patch -p0 -i ${srcdir}/make_install.patch
+
+ # patch to get UTF8 and available fonts
+ patch -p0 -i ${srcdir}/therion_ini.patch
+
+ make
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}
diff --git a/loch-makefile-vtk-6.1.patch b/loch_vtk7.patch
index 90d4e3611553..3f13b7e8055b 100644
--- a/loch-makefile-vtk-6.1.patch
+++ b/loch_vtk7.patch
@@ -1,21 +1,21 @@
---- Makefile.old 2015-10-06 18:41:14.575020302 +0200
-+++ Makefile 2015-10-07 12:44:53.790503202 +0200
-@@ -16,10 +16,10 @@
- lxGUI.o lxGLC.o lxOptDlg.o lxAboutDlg.o lxPres.o \
- img.o
+--- loch/Makefile_raw 2017-04-03 22:32:08.000000000 +0200
++++ loch/Makefile 2017-04-10 18:52:01.320200225 +0200
+@@ -19,10 +19,10 @@
+ CROSS =
+ EXT =
-VTKVERSION = $(shell tclsh ./getvtkver.tcl version)
-VTKPATH = $(shell tclsh ./getvtkver.tcl incpath)
-VTKLIBPATH = $(shell tclsh ./getvtkver.tcl libpath)
-VTKV6 = $(shell tclsh ./getvtkver.tcl version6)
-+VTKVERSION = 6.1
-+VTKPATH = "/usr/include/vtk/"
++VTKVERSION = 7.1
++VTKPATH = "/usr/include/vtk/"
+VTKLIBPATH = "/usr/lib"
+VTKV6 = 1
ifeq ($(VTKV6),1)
VTKLIBS = -lvtkCommonExecutionModel-$(VTKVERSION) -lvtkCommonDataModel-$(VTKVERSION) -lvtkCommonCore-$(VTKVERSION) -lvtkFiltersCore-$(VTKVERSION) -lvtkFiltersHybrid-$(VTKVERSION) -lvtkIOLegacy-$(VTKVERSION) -lfreetype -lpng -ljpeg
else
-@@ -53,7 +53,7 @@
+@@ -56,7 +56,7 @@
CC = gcc
POBJECTS = lxR2P.o
ifeq ($(VTKV6),1)
diff --git a/makefile-install-path.patch b/make_install.patch
index 9b54b82a71fd..b79ceb956b13 100644
--- a/makefile-install-path.patch
+++ b/make_install.patch
@@ -1,17 +1,16 @@
---- Makefile.old 2014-12-30 10:55:53.000000000 +0100
-+++ Makefile 2015-10-15 13:15:59.382996691 +0200
-@@ -144,8 +144,7 @@
+--- Makefile_raw 2017-04-03 22:32:08.000000000 +0200
++++ Makefile 2017-04-11 09:10:58.900793485 +0200
+@@ -171,7 +171,7 @@
./therion --print-init-file > therion.ini
install: all
- tclsh makeinstall.tcl $(THPLATFORM)
--
+ tclsh makeinstall.tcl $(THPLATFORM) $(DESTDIR)
minor-release:
perl makerelease.pl
---- makeinstall.tcl.old 2015-10-15 13:48:43.099676241 +0200
-+++ makeinstall.tcl 2015-10-15 13:49:56.933010051 +0200
+--- makeinstall.tcl_raw 2017-04-03 22:32:08.000000000 +0200
++++ makeinstall.tcl 2017-04-11 09:15:00.960791964 +0200
@@ -2,6 +2,7 @@
set instdir /usr/local
if {$argc > 0} {
@@ -20,17 +19,16 @@
} else {
if {[string equal $tcl_platform(platform) windows]} {
set platform WIN32
-@@ -10,6 +11,9 @@
+@@ -10,6 +11,8 @@
proc copyfile {force src dst} {
if {$force} {
-+ set dirname [file dirname $dst]
-+ file mkdir $dirname
-+
++ set dirname [file dirname $dst]
++ file mkdir $dirname
if {[catch {
file copy -force -- $src $dst
}]} {
-@@ -50,9 +54,9 @@
+@@ -50,9 +53,9 @@
copyfile 0 xtherion/xtherion.ini /etc/xtherion.ini
file attributes /etc/xtherion.ini -permissions 0644
} else {
diff --git a/therion-ini.patch b/therion_ini.patch
index 620baecf8afb..0f6c13fb64da 100644
--- a/therion-ini.patch
+++ b/therion_ini.patch
@@ -1,13 +1,13 @@
---- therion.ini.old 2011-06-18 10:31:38.000000000 +0200
-+++ therion.ini 2015-12-29 02:18:42.993104037 +0100
-@@ -1,5 +1,5 @@
+--- therion.ini_raw 2017-04-03 22:32:08.000000000 +0200
++++ therion.ini 2017-04-11 09:46:37.830780039 +0200
+@@ -1,5 +1,6 @@
### Output character encodings ###
--# encoding-default ASCII
+ # encoding-default ASCII
+encoding-default UTF-8
# encoding-sql ASCII
### Default regional settings ###
-@@ -23,7 +23,7 @@
+@@ -23,7 +24,7 @@
### Tex initialization ###
# tex-env off
# tex-fonts <encoding> <roman> <italic> <bold> <sansserif> <sansserifoblique>