summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzezadas2020-05-27 12:16:21 +0100
committerzezadas2020-05-27 12:16:21 +0100
commitadc30ce9141303e30d6c73f856309d8d23fd6afe (patch)
tree23edfc5d2f71a07473cb30bbfe9f7497d3a76f24
downloadaur-adc30ce9141303e30d6c73f856309d8d23fd6afe.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD49
-rw-r--r--modules-load-thermald.conf2
-rw-r--r--uninitialized_vars-fix.patch13
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c8d96962ddf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = thermald-git-gcc10
+ pkgdesc = The Linux Thermal Daemon program from 01.org
+ pkgver = v2.1.r2.g3f3cdc3
+ pkgrel = 1
+ url = https://01.org/linux-thermal-daemon
+ arch = x86_64
+ license = GPL2
+ makedepends = systemd
+ makedepends = python
+ makedepends = autoconf-archive
+ depends = dbus-glib
+ depends = libxml2
+ provides = thermald
+ conflicts = thermald
+ source = thermald-git-gcc10::git://github.com/intel/thermal_daemon
+ source = modules-load-thermald.conf
+ source = uninitialized_vars-fix.patch
+ sha256sums = SKIP
+ sha256sums = 0155e1eb459306d251a5a049ffc6c11e144fa8caa75901ac5fa20bd52e05d515
+ sha256sums = fa71590c04cb0d1cd3db2d543f2402d887e7b12708f00a3af3005b1a000444df
+
+pkgname = thermald-git-gcc10
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5f7359d0fce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Zezadas <aur at sefod dot eu>
+# Forked from https://aur.archlinux.org/packages/thermald/
+
+pkgname=thermald-git-gcc10
+pkgver=v2.1.r2.g3f3cdc3
+pkgrel=1
+pkgdesc="The Linux Thermal Daemon program from 01.org"
+arch=('x86_64')
+url="https://01.org/linux-thermal-daemon"
+license=('GPL2')
+makedepends=('systemd' 'python' 'autoconf-archive')
+depends=('dbus-glib' 'libxml2')
+conflicts=('thermald')
+provides=('thermald')
+source=(${pkgname}::"git://github.com/intel/thermal_daemon"
+ 'modules-load-thermald.conf'
+ 'uninitialized_vars-fix.patch')
+sha256sums=('SKIP'
+ '0155e1eb459306d251a5a049ffc6c11e144fa8caa75901ac5fa20bd52e05d515'
+ 'fa71590c04cb0d1cd3db2d543f2402d887e7b12708f00a3af3005b1a000444df')
+
+pkgver() {
+ cd "${pkgname}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ cd ${pkgname}
+ patch -p1 -i ${srcdir}/uninitialized_vars-fix.patch
+
+}
+
+build() {
+ cd ${pkgname}
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}"/modules-load-thermald.conf "${pkgdir}"/usr/lib/modules-load.d/thermald.conf
+}
diff --git a/modules-load-thermald.conf b/modules-load-thermald.conf
new file mode 100644
index 000000000000..a8b98118af89
--- /dev/null
+++ b/modules-load-thermald.conf
@@ -0,0 +1,2 @@
+msr
+coretemp
diff --git a/uninitialized_vars-fix.patch b/uninitialized_vars-fix.patch
new file mode 100644
index 000000000000..94208d791a83
--- /dev/null
+++ b/uninitialized_vars-fix.patch
@@ -0,0 +1,13 @@
+--- thermal_daemon-2.1/src/thd_cpu_default_binding.cpp 2020-04-24 23:47:35.000000000 +0100
++++ thermal_daemon-2.1-new/src/thd_cpu_default_binding.cpp 2020-05-27 11:50:39.108623588 +0100
+@@ -187,8 +187,8 @@
+ }
+
+ bool cthd_cpu_default_binding::check_cpu_load() {
+- unsigned int max_power;
+- unsigned int min_power;
++ unsigned int max_power=0;
++ unsigned int min_power=0;
+ unsigned int power;
+
+ power = thd_engine->rapl_power_meter.rapl_action_get_power(PACKAGE,