summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-01 21:05:46 -0500
committerlmartinez-mirror2021-04-01 21:05:46 -0500
commita38b69dd97ddc7d4978b75b5e8f49545cb44bf98 (patch)
treec81f8a7e6b24afdcb1cb5ce11553a65fbd86f0be
downloadaur-a38b69dd97ddc7d4978b75b5e8f49545cb44bf98.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..050c389d48d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = thermofun-git
+ pkgdesc = Library for calculating standard state thermodynamic properties
+ pkgver = 0.3.7.r0.gf4da39b
+ pkgrel = 1
+ url = https://github.com/thermohub/thermofun
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = nlohmann-json
+ makedepends = pybind11
+ makedepends = python-setuptools
+ depends = gcc-libs
+ depends = python
+ provides = thermofun
+ provides = libThermoFun.so
+ conflicts = thermofun
+ source = thermofun-git::git+https://github.com/thermohub/thermofun
+ md5sums = SKIP
+
+pkgname = thermofun-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f5b1408bd0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: lmartinez-mirror
+pkgname=thermofun-git
+pkgver=0.3.7.r0.gf4da39b
+pkgrel=1
+pkgdesc="Library for calculating standard state thermodynamic properties"
+arch=('x86_64')
+url="https://github.com/thermohub/thermofun"
+license=('LGPL3')
+depends=('gcc-libs' 'python')
+makedepends=('git' 'cmake' 'nlohmann-json' 'pybind11' 'python-setuptools')
+provides=('thermofun' 'libThermoFun.so')
+conflicts=('thermofun')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" \
+ -DCMAKE_SKIP_RPATH=YES \
+ -S "$pkgname" \
+ -B build
+ make -C build
+}
+
+package() {
+ make install -C build
+}