summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2016-03-30 16:24:34 +1100
committerVictor Tran2016-03-30 16:24:34 +1100
commit1836f80ca20c13583842c5d93a0d4dc16c5eaa95 (patch)
treeb643ab9e8dfe059177d7d8dbef0f139295f1c343
downloadaur-1836f80ca20c13583842c5d93a0d4dc16c5eaa95.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3416ff0ec2cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = theshell
+ pkgdesc = Minimalistic Desktop Shell
+ pkgver = 1.0
+ pkgrel = 2
+ url = https://github.com/vicr123/thefile
+ arch = x86_64
+ license = GPL2
+ makedepends = qtchooser
+ makedepends = git
+ depends = kwidgetsaddons
+ depends = xdg-utils
+ depends = wmctrl
+ depends = kwin
+ depends = NetworkManager
+ optdepends = pocketsphinx: for theWave
+ optdepends = festival: for theWave
+ source = theshell-1.0::git+https://github.com/vicr123/theshell#branch=master
+ md5sums = SKIP
+
+pkgname = theshell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bf84e2ded6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=theshell
+pkgver=1.0
+pkgrel=2
+pkgdesc="Minimalistic Desktop Shell"
+arch=("x86_64")
+url="https://github.com/vicr123/thefile"
+license=('GPL2')
+depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin' 'NetworkManager')
+optdepends=('pocketsphinx: for theWave'
+ 'festival: for theWave')
+makedepends=('qtchooser' 'git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qdbuscpp2xml -M -s notificationdbus.h -o org.freedesktop.Notifications.xml
+ qmake theShell.pro -r -spec linux-clang
+ make
+}
+
+package() {
+ chmod +x "$pkgname-$pkgver/init_theshell"
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/theshell" "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/init_theshell" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/xsessions"
+ cp "$pkgname-$pkgver/theshell.desktop" "$pkgdir/usr/share/xsessions"
+}