summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2016-05-01 22:07:23 +1000
committerVictor Tran2016-05-01 22:07:23 +1000
commitc3454eeca2914ff0ccc79d95eb776cd1778d3a18 (patch)
tree414937e1b36dfa23ad0cc794cacfc161ac8032cc
parent01768a77218d03a91273f915330a64a1fe2a7f96 (diff)
downloadaur-c3454eeca2914ff0ccc79d95eb776cd1778d3a18.tar.gz
Update to 1.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb47fe536884..67395e7fcf65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = theshell
pkgdesc = Desktop Shell that gets out of your way
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 0
url = https://github.com/vicr123/theshell
arch = x86_64
license = GPL3
makedepends = qtchooser
makedepends = git
- makedepends = clang
depends = kwidgetsaddons
depends = xdg-utils
depends = wmctrl
depends = kwin
depends = networkmanager
depends = xorg-xbacklight
+ depends = redshift
optdepends = alsa-utils: for volume controls
optdepends = pocketsphinx: for theWave
optdepends = festival: for theWave
- source = theshell-1.2::git+https://github.com/vicr123/theshell#branch=master
+ source = theshell-1.3::git+https://github.com/vicr123/theshell#branch=master
md5sums = SKIP
pkgname = theshell
diff --git a/PKGBUILD b/PKGBUILD
index 638c281c07ac..d5e1d34b872a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theshell
-pkgver=1.2
+pkgver=1.3
pkgrel=0
pkgdesc="Desktop Shell that gets out of your way"
arch=("x86_64")
url="https://github.com/vicr123/theshell"
license=('GPL3')
-depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin' 'networkmanager' 'xorg-xbacklight')
+depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin' 'networkmanager' 'xorg-xbacklight' 'redshift')
optdepends=('alsa-utils: for volume controls'
'pocketsphinx: for theWave'
'festival: for theWave')
-makedepends=('qtchooser' 'git' 'clang')
+makedepends=('qtchooser' 'git')
source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=master')
md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
qdbuscpp2xml -M -s notificationdbus.h -o org.freedesktop.Notifications.xml
- qmake theShell.pro -r -spec linux-clang
+ qmake theShell.pro
make
}