summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-12-11 10:09:58 +1100
committerVictor Tran2017-12-11 10:09:58 +1100
commite9d6248b1eea40643798ff78884798c0355eb144 (patch)
tree9b5bebc0967b6f0f004b954f59881ae7c94db5a4
parent671a6b370a333852117433ca5e3cd92397db4618 (diff)
downloadaur-e9d6248b1eea40643798ff78884798c0355eb144.tar.gz
Update conflicts
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 16 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ef42cac6c8c..514fc4c0e43e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = theshell
pkgdesc = Desktop Shell that gets out of your way
- pkgver = 7.0
- pkgrel = 0
+ pkgver = 7.1
+ pkgrel = 1
url = https://github.com/vicr123/theshell
arch = x86_64
- arch = i686
license = GPL3
makedepends = git
depends = kwidgetsaddons
@@ -18,20 +17,17 @@ pkgbase = theshell
depends = libcups
depends = qt5-base
depends = ts-qtplatform
- depends = the-libs
depends = qt5-charts
depends = qt5-location
depends = kscreen
depends = kdepimlibs4
- depends = akonadi
depends = ts-polkitagent
depends = ts-bt
depends = ts-bugreport
- depends = ts-startsession
optdepends = alsa-utils: for volume controls
- optdepends = pocketsphinx: for theWave
- optdepends = festival: for theWave
- source = theshell-7.0::git+https://github.com/vicr123/theshell#branch=master
+ conflicts = ts-startsession
+ replaces = ts-startsession
+ source = theshell-7.1::git+https://github.com/vicr123/theshell#branch=blueprint
md5sums = SKIP
pkgname = theshell
diff --git a/PKGBUILD b/PKGBUILD
index 3247e906c1da..35e705023ff2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,30 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theshell
-pkgver=7.0
-pkgrel=0
+pkgver=7.1
+pkgrel=1
pkgdesc="Desktop Shell that gets out of your way"
-arch=("x86_64" "i686")
+arch=("x86_64")
url="https://github.com/vicr123/theshell"
license=('GPL3')
depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin'
'networkmanager' 'xorg-xbacklight' 'redshift' 'tsscreenlock'
-'libcups' 'qt5-base' 'ts-qtplatform' 'the-libs' 'qt5-charts'
-'qt5-location' 'kscreen' 'kdepimlibs4' 'akonadi' 'ts-polkitagent' 'ts-bt' 'ts-bugreport' 'ts-startsession')
-optdepends=('alsa-utils: for volume controls'
- 'pocketsphinx: for theWave'
- 'festival: for theWave')
+'libcups' 'qt5-base' 'ts-qtplatform' 'qt5-charts'
+'qt5-location' 'kscreen' 'kdepimlibs4' 'ts-polkitagent' 'ts-bt' 'ts-bugreport')
+optdepends=('alsa-utils: for volume controls')
makedepends=('git')
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=master')
+conflicts=('ts-startsession')
+replaces=('ts-startsession')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=blueprint')
md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
- qdbuscpp2xml -M -s notificationdbus.h -o org.freedesktop.Notifications.xml
- qdbuscpp2xml -a -o org.thesuite.power.xml upowerdbus.h
- qdbuscpp2xml -a -o org.thesuite.theshell.xml dbussignals.h
qmake theShell.pro
make
}
package() {
- chmod +x "$pkgname-$pkgver/init_theshell"
- mkdir -p "$pkgdir/usr/bin"
- cp "$pkgname-$pkgver/theshell" "$pkgdir/usr/bin"
- cp "$pkgname-$pkgver/init_theshell" "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/xsessions"
- cp "$pkgname-$pkgver/theshell.desktop" "$pkgdir/usr/share/xsessions"
- mkdir -p "$pkgdir/usr/share/theshell/translations"
- cp "$pkgname-$pkgver/translations/"* "$pkgdir/usr/share/theshell/translations"
+ cd "$pkgname-$pkgver"
+ make install INSTALL_ROOT=$pkgdir
}