summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2021-01-12 20:57:53 +1100
committerVictor Tran2021-01-12 20:58:29 +1100
commit90be722ac3fa733eb197923799bf319f8adfa2ec (patch)
tree680c7f846dbc72eb187df6dd78c1721425601888
downloadaur-theshop.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb84dad4a9f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = theshop
+ pkgdesc = Software store
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/theshop
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = libthedesk
+ makedepends = thedesk
+ depends = qt5-base
+ depends = the-libs
+ depends = qt5-svg
+ depends = appstream-qt
+ depends = packagekit-qt5
+ source = theshop-1.0::https://github.com/vicr123/theShop/archive/v1.0.tar.gz
+ sha256sums = 90f836280fc68eb4a21df25d3633b3276b96ac3fdc4dd7dbba099bbdb504ea33
+
+pkgname = theshop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62ea9dbc0d16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=theshop
+pkgver=1.0
+pkgrel=0
+pkgdesc="Software store"
+arch=("x86_64")
+url="https://github.com/vicr123/theshop"
+license=('GPL3')
+depends=('qt5-base' 'the-libs' 'qt5-svg' 'appstream-qt' 'packagekit-qt5')
+makedepends=('git' 'qt5-tools' 'libthedesk' 'thedesk')
+source=("$pkgname-$pkgver"::"https://github.com/vicr123/theShop/archive/v1.0.tar.gz")
+sha256sums=('90f836280fc68eb4a21df25d3633b3276b96ac3fdc4dd7dbba099bbdb504ea33')
+
+build() {
+ cd "theShop-$pkgver"
+ mkdir -p build
+ cd build
+ qmake ../theShop.pro
+ make
+}
+
+package() {
+ cd "theShop-$pkgver"
+ cd build
+ make install INSTALL_ROOT=$pkgdir
+}