summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:51:55 +0200
committerStefan Husmann2015-06-09 00:51:55 +0200
commited02c970c507959ef6e221a7ad58496a6c588ee4 (patch)
tree7f2989d18299b1cf5f4680d49ffadcd4e0c51ace
downloadaur-ed02c970c507959ef6e221a7ad58496a6c588ee4.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
-rw-r--r--thesis.install14
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7853c1ea939f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = thesis
+ pkgdesc = Two LaTeX classes for bigger, thesis-like documents
+ pkgver = 1.0
+ pkgrel = 3
+ url = http://dante.ctan.org/CTAN/help/Catalogue/entries/thesis.html#Visit
+ install = thesis.install
+ arch = any
+ license = LPPL
+ depends = texlive-core
+ source = http://dante.ctan.org/CTAN/macros/latex/contrib/thesis.zip
+ md5sums = 8c6e19dfbbd919c84abf939f12d8a8b9
+
+pkgname = thesis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bce35a3e5fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=thesis
+pkgver=1.0
+pkgrel=3
+pkgdesc="Two LaTeX classes for bigger, thesis-like documents"
+url="http://dante.ctan.org/CTAN/help/Catalogue/entries/thesis.html#Visit"
+arch=('any')
+license=('LPPL')
+depends=('texlive-core')
+install=thesis.install
+source=(http://dante.ctan.org/CTAN/macros/latex/contrib/$pkgname.zip)
+md5sums=('8c6e19dfbbd919c84abf939f12d8a8b9')
+
+build() {
+ cd $srcdir/$pkgname
+ yes | latex install.01 || return 1
+ yes | latex install.ndx || return 1
+ install -Dm644 makendx.sty \
+ $pkgdir/usr/share/texmf/tex/latex/$pkgname/makendx.sty || return 1
+ install -Dm644 thema.sty \
+ $pkgdir/usr/share/texmf/tex/latex/$pkgname/thema.sty || return 1
+ install -Dm644 thema.cls \
+ $pkgdir/usr/share/texmf/tex/latex/$pkgname/thema.cls || return 1
+ install -Dm644 thesis.sty \
+ $pkgdir/usr/share/texmf/tex/latex/$pkgname/thesis.sty || return 1
+ install -Dm644 thesis.cls \
+ $pkgdir/usr/share/texmf/tex/latex/$pkgname/thesis.cls || return 1
+ install -Dm644 makendx.ist \
+ $pkgdir/usr/share/texmf/makeindex/$pkgname/makendx.ist || return 1
+ install -Dm644 thesis.pdf \
+ $pkgdir/usr/share/texmf/doc/$pkgname/thesis.pdf || return 1
+}
diff --git a/thesis.install b/thesis.install
new file mode 100644
index 000000000000..a86478bd65c7
--- /dev/null
+++ b/thesis.install
@@ -0,0 +1,14 @@
+# arg 1: the new package version
+post_install() {
+ texconfig-sys rehash
+}
+
+post_upgrade() {
+ texconfig-sys rehash
+}
+
+op=$1
+shift
+[ "$(type -t "$op")" = "function" ] && $op "$@"
+
+# vim:set ts=2 sw=2 et: