summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2023-06-09 19:57:54 +1000
committerVictor Tran2023-06-09 19:57:54 +1000
commit5f44016cf745274754977f2f2e08bb4e2393d1c4 (patch)
tree659d67e727fc92122fbd4664d19eafd7fe34b845
parentd5da1ba5d5fd5f36b61fedbd9e6b076cf6304fb6 (diff)
downloadaur-5f44016cf745274754977f2f2e08bb4e2393d1c4.tar.gz
Update to 4.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dafb508eb900..ee0e26fd9b0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = theterminal
pkgdesc = Simple Terminal Emulator
- pkgver = 3.0
+ pkgver = 4.0
pkgrel = 0
- url = https://github.com/vicr123/theterminal
+ url = https://github.com/theCheeseboard/theterminal
arch = x86_64
+ arch = aarch64
license = GPL3
- makedepends = qt5-tools
+ makedepends = git
+ makedepends = qt6-tools
+ makedepends = cmake
+ makedepends = clang
depends = xdg-utils
depends = tttermwidget
- depends = qt5-base
- depends = qt5-x11extras
- depends = the-libs
- source = theterminal-3.0::https://github.com/vicr123/theterminal/archive/v3.0.tar.gz
- sha256sums = ae129556502549293ef090afa2954389353c70d6a5d7c6f8a838bbaacaa607e9
+ source = theterminal::https://github.com/theCheeseboard/theterminal/archive/v4.0.tar.gz
+ sha256sums = 985e820fbc3ff2d70807474813cb0efbc38ef4616400e57055b2f18bcf266323
pkgname = theterminal
-
diff --git a/PKGBUILD b/PKGBUILD
index 23300f7d69e0..2ae21f51586d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theterminal
-pkgver=3.0
+pkgver=4.0
pkgrel=0
pkgdesc="Simple Terminal Emulator"
-arch=("x86_64")
-url="https://github.com/vicr123/theterminal"
+arch=("x86_64" "aarch64")
+url="https://github.com/theCheeseboard/theterminal"
license=('GPL3')
-depends=('xdg-utils' 'tttermwidget' 'qt5-base' 'qt5-x11extras' 'the-libs')
-makedepends=('qt5-tools')
-source=("$pkgname-$pkgver"::'https://github.com/vicr123/theterminal/archive/v3.0.tar.gz')
-sha256sums=('ae129556502549293ef090afa2954389353c70d6a5d7c6f8a838bbaacaa607e9')
+depends=('xdg-utils' 'tttermwidget')
+makedepends=('git' 'qt6-tools' 'cmake' 'clang')
+source=("theterminal"::"https://github.com/theCheeseboard/theterminal/archive/v$pkgver.tar.gz")
+sha256sums=('985e820fbc3ff2d70807474813cb0efbc38ef4616400e57055b2f18bcf266323')
build() {
- cd "$pkgname-$pkgver"
- qmake
- make
+ cmake -B build -S "$pkgname-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
- cd "$pkgname-$pkgver"
- make install INSTALL_ROOT=$pkgdir
+ DESTDIR="$pkgdir" cmake --install "build"
}