summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-05-29 11:50:17 -0600
committerMark Wagie2022-05-29 11:50:17 -0600
commit0e5c9b03382fc86f617067bb2ef680ed39195e52 (patch)
tree5431bd8ec4ac772309cf79fdd6d20066e849aad2
parentd5d850f2bab718d4bbcb8fd7c5b733d2a77bfa90 (diff)
downloadaur-0e5c9b03382fc86f617067bb2ef680ed39195e52.tar.gz
use git commit hash instead of tag
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9621a120fbef..661ec78581e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,7 +18,7 @@ pkgbase = thiefmd
depends = link-grammar
depends = libhandy
depends = webkit2gtk
- source = git+https://github.com/kmwallio/ThiefMD.git#tag=v0.2.5-stability
+ source = git+https://github.com/kmwallio/ThiefMD.git#commit=039ec4f81170b468d2eb5cf3b9e0b0cae7b59097
source = git+https://github.com/ThiefMD/BiBtex-vala.git
source = git+https://github.com/ThiefMD/ghost-vala.git
source = git+https://github.com/TwiRp/ultheme-vala.git
diff --git a/PKGBUILD b/PKGBUILD
index 2a52263162b1..7c796b30249c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,8 @@ license=('GPL3')
depends=('clutter' 'discount' 'gtksourceview4' 'gtkspell3' 'libarchive' 'libgee'
'link-grammar' 'libhandy' 'webkit2gtk')
makedepends=('git' 'meson' 'vala')
-source=("git+https://github.com/kmwallio/ThiefMD.git#tag=v$pkgver-$_codename"
+_commit=039ec4f81170b468d2eb5cf3b9e0b0cae7b59097
+source=("git+https://github.com/kmwallio/ThiefMD.git#commit=${_commit}"
'git+https://github.com/ThiefMD/BiBtex-vala.git'
'git+https://github.com/ThiefMD/ghost-vala.git'
'git+https://github.com/TwiRp/ultheme-vala.git'
@@ -29,7 +30,7 @@ sha256sums=('SKIP'
pkgver() {
cd "$srcdir/ThiefMD"
- git describe --tags | sed "s/^v//;s/-$_codename//;s/-/+/g"
+ git describe --tags | sed "s/^v//;s/-${_codename}//;s/-/+/g"
}
prepare() {