summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-10-06 14:19:36 -0600
committerMark Wagie2020-10-06 14:19:36 -0600
commit44c32ef6ace22fae1be5aede06c6d3a511f2540a (patch)
treea26f498a33b3e3f62741944526b8d5579f5b32f8
downloadaur-44c32ef6ace22fae1be5aede06c6d3a511f2540a.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD36
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1a835c5aa88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = thiefmd
+ pkgdesc = The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter
+ pkgver = 0.0.12
+ pkgrel = 1
+ url = https://thiefmd.com
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ makedepends = cmake
+ makedepends = python-gobject
+ depends = gtkspell3
+ depends = webkit2gtk
+ depends = discount
+ depends = gtksourceview3
+ depends = clutter
+ depends = libarchive
+ depends = libgee
+ source = thiefmd-0.0.12.tar.gz::https://github.com/kmwallio/ThiefMD/archive/v0.0.12-luminance.tar.gz
+ sha256sums = af4f3317f42f2d68a30ba325260f8d515253b2c0bbeeeba87d32643e3e717b95
+
+pkgname = thiefmd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b995d7de815d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=thiefmd
+pkgver=0.0.12
+_codename=luminance
+pkgrel=1
+pkgdesc="The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter"
+arch=('x86_64')
+url="https://thiefmd.com"
+license=('GPL3')
+depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview3' 'clutter' 'libarchive' 'libgee')
+makedepends=('git' 'meson' 'vala' 'cmake' 'python-gobject')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kmwallio/ThiefMD/archive/v$pkgver-$_codename.tar.gz")
+sha256sums=('af4f3317f42f2d68a30ba325260f8d515253b2c0bbeeeba87d32643e3e717b95')
+
+build() {
+ meson \
+ --prefix /usr \
+ --libexecdir lib \
+ --sbindir bin \
+ --buildtype plain \
+ --auto-features enabled \
+ -D b_lto=true \
+ -D b_pie=true \
+ ThiefMD-$pkgver-$_codename build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+
+ ln -s /usr/bin/com.github.kmwallio.thiefmd "$pkgdir/usr/bin/$pkgname"
+}