summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-14 06:12:30 -0600
committerMark Wagie2021-03-14 06:12:30 -0600
commit4dbf25773b4f7a8dcd35a9a7c5599a26607b751e (patch)
tree2bc2db8840ae9a62048481f15298f049be1aafa1
parent2f1568c997cd0ad60560622e996113ca675ad970 (diff)
downloadaur-4dbf25773b4f7a8dcd35a9a7c5599a26607b751e.tar.gz
0.1.7
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c27aff94e08..7ed3c3e59051 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thiefmd
pkgdesc = The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter
- pkgver = 0.1.6
+ pkgver = 0.1.7
pkgrel = 1
url = https://thiefmd.com
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = thiefmd
depends = clutter
depends = libgee
depends = libhandy
- source = git+https://github.com/kmwallio/ThiefMD.git#commit=174939c062781695596ba53616386c541f0857bc
+ source = git+https://github.com/kmwallio/ThiefMD.git#commit=213f2fa1e72cd3d9830cf1d1f0c6c0106f715822
source = git+https://github.com/ThiefMD/ghost-vala.git
source = git+https://github.com/TwiRp/ultheme-vala.git
source = git+https://github.com/ThiefMD/wordpress-vala.git
diff --git a/PKGBUILD b/PKGBUILD
index 84077a2e1d90..f200a9fb57b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=thiefmd
-pkgver=0.1.6
-_codename=finess
+pkgver=0.1.7
+_codename=subtle
pkgrel=1
pkgdesc="The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter"
arch=('x86_64' 'aarch64')
@@ -10,7 +10,7 @@ license=('GPL3')
depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview4' 'libarchive'
'clutter' 'libgee' 'libhandy')
makedepends=('git' 'meson' 'vala')
-_commit=174939c062781695596ba53616386c541f0857bc
+_commit=213f2fa1e72cd3d9830cf1d1f0c6c0106f715822
source=("git+https://github.com/kmwallio/ThiefMD.git#commit=$_commit"
'git+https://github.com/ThiefMD/ghost-vala.git'
'git+https://github.com/TwiRp/ultheme-vala.git'
@@ -32,11 +32,9 @@ pkgver() {
prepare() {
cd "$srcdir/ThiefMD"
git submodule init
- git config submodule.src/ghost.url $srcdir/ghost-vala
- git config submodule.src/ultheme.url $srcdir/ultheme-vala
- git config submodule.src/wordpress.url $srcdir/wordpress-vala
- git config submodule.src/writeas.url $srcdir/writeas-vala
- git config submodule.src/writegood.url $srcdir/libwritegood-vala
+ for _submodule in ghost-vala ultheme-vala wordpress-vala writeas-vala libwritegood-vala; do
+ git config submodule.src/${_submodule}.url $srcdir/${_submodule}
+ done
git submodule update
}