summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-10-23 21:01:53 -0600
committerMark Wagie2020-10-23 21:01:53 -0600
commit640a774f1f26a2a98d3aa5610158499b52dd0a8d (patch)
treeefe932b811a6ad17e7dc50adc44281bc26b73a68
parent195b010f26758c871e406dc398955f7a97966939 (diff)
downloadaur-640a774f1f26a2a98d3aa5610158499b52dd0a8d.tar.gz
0.1.2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a639af7fddb5..9bac6a059f4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thiefmd
pkgdesc = The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter
- pkgver = 0.1.1
+ pkgver = 0.1.2
pkgrel = 1
url = https://thiefmd.com
arch = x86_64
@@ -12,16 +12,19 @@ pkgbase = thiefmd
depends = webkit2gtk
depends = discount
depends = gtksourceview4
- depends = libxml2
depends = libarchive
depends = clutter
depends = libgee
- source = git+https://github.com/kmwallio/ThiefMD.git#commit=a903cdcf0076938778f05bfcf36e4c16a28ca438
+ source = git+https://github.com/kmwallio/ThiefMD.git#commit=14ddac2af428864478bf99d14ae0e3ac9fd76a95
+ source = git+https://github.com/ThiefMD/ghost-vala.git
source = git+https://github.com/TwiRp/ultheme-vala.git
+ source = git+https://github.com/ThiefMD/writeas-vala.git
source = git+https://github.com/ThiefMD/libwritegood-vala.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = thiefmd
diff --git a/PKGBUILD b/PKGBUILD
index bfe7d0398ad0..b9b936bf014c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=thiefmd
-pkgver=0.1.1
-_codename=notnanoprep
+pkgver=0.1.2
+_codename=sophistication
pkgrel=1
pkgdesc="The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter"
arch=('x86_64')
url="https://thiefmd.com"
license=('GPL3')
-depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview4' 'libxml2' 'libarchive'
+depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview4' 'libarchive'
'clutter' 'libgee')
makedepends=('git' 'meson' 'vala')
#source=("$pkgname-$pkgver.tar.gz::https://github.com/kmwallio/ThiefMD/archive/v$pkgver-$_codename.tar.gz")
-_commit=a903cdcf0076938778f05bfcf36e4c16a28ca438
+_commit=14ddac2af428864478bf99d14ae0e3ac9fd76a95
source=("git+https://github.com/kmwallio/ThiefMD.git#commit=$_commit"
+ 'git+https://github.com/ThiefMD/ghost-vala.git'
'git+https://github.com/TwiRp/ultheme-vala.git'
+ 'git+https://github.com/ThiefMD/writeas-vala.git'
'git+https://github.com/ThiefMD/libwritegood-vala.git')
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -27,8 +31,10 @@ pkgver() {
prepare() {
cd "$srcdir/ThiefMD"
git submodule init
- git config submodule.src/ultheme-vala.url $srcdir/ultheme-vala
- git config submodule.src/libwritegood-vala.url $srcdir/libwritegood-vala
+ git config submodule.src/ghost.url $srcdir/ghost-vala
+ git config submodule.src/ultheme.url $srcdir/ultheme-vala
+ git config submodule.src/writeas.url $srcdir/writeas-vala
+ git config submodule.src/writegood.url $srcdir/libwritegood-vala
git submodule update
}
@@ -37,10 +43,6 @@ build() {
meson compile -C build
}
-check() {
- meson test -C build --print-errorlogs
-}
-
package() {
DESTDIR="$pkgdir" meson install -C build