summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-10-10 21:52:34 -0600
committerMark Wagie2020-10-10 21:52:34 -0600
commitaa68b66409c6ca1755c243949dd0f912354a879a (patch)
tree55488c5744b47d47af1095e4cafd12d0a87bc842
parente4e657bb8f3dc39b4280eb17bdae76ce63704070 (diff)
downloadaur-aa68b66409c6ca1755c243949dd0f912354a879a.tar.gz
0.1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 39 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5db4804f8b84..8f49f640f094 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
pkgbase = thiefmd
pkgdesc = The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter
- pkgver = 0.0.12
- pkgrel = 4
+ pkgver = 0.1.0
+ pkgrel = 1
url = https://thiefmd.com
arch = x86_64
license = GPL3
makedepends = git
makedepends = meson
makedepends = vala
- makedepends = cmake
- makedepends = python-gobject
depends = gtkspell3
depends = webkit2gtk
depends = discount
- depends = gtksourceview3
- depends = gxml
+ depends = gtksourceview4
+ depends = libxml2
depends = libarchive
depends = clutter
depends = libgee
conflicts = ultheme-vala
conflicts = libwritegood-vala
- source = thiefmd-0.0.12.tar.gz::https://github.com/kmwallio/ThiefMD/archive/v0.0.12-luminance.tar.gz
- sha256sums = af4f3317f42f2d68a30ba325260f8d515253b2c0bbeeeba87d32643e3e717b95
+ source = git+https://github.com/kmwallio/ThiefMD.git#commit=906f8ea9e35e415104cbb7963743be23af5ded4a
+ source = git+https://github.com/TwiRp/ultheme-vala.git
+ source = git+https://github.com/ThiefMD/libwritegood-vala.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = thiefmd
diff --git a/PKGBUILD b/PKGBUILD
index a9517252db65..9d9aa2f511c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,41 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=thiefmd
-pkgver=0.0.12
-_codename=luminance
-pkgrel=4
+pkgver=0.1.0
+_codename=inandout
+pkgrel=1
pkgdesc="The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter"
arch=('x86_64')
url="https://thiefmd.com"
license=('GPL3')
-depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview3' 'gxml' 'libarchive' 'clutter' 'libgee')
-makedepends=('git' 'meson' 'vala' 'cmake' 'python-gobject')
+depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview4' 'libxml2' 'libarchive'
+ 'clutter' 'libgee')
+makedepends=('git' 'meson' 'vala')
conflicts=('ultheme-vala' 'libwritegood-vala')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/kmwallio/ThiefMD/archive/v$pkgver-$_codename.tar.gz")
-sha256sums=('af4f3317f42f2d68a30ba325260f8d515253b2c0bbeeeba87d32643e3e717b95')
+#source=("$pkgname-$pkgver.tar.gz::https://github.com/kmwallio/ThiefMD/archive/v$pkgver-$_codename.tar.gz")
+_commit=906f8ea9e35e415104cbb7963743be23af5ded4a
+source=("git+https://github.com/kmwallio/ThiefMD.git#commit=$_commit"
+ 'git+https://github.com/TwiRp/ultheme-vala.git'
+ 'git+https://github.com/ThiefMD/libwritegood-vala.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+
+pkgver() {
+ cd "$srcdir/ThiefMD"
+ git describe --tags | sed "s/^v//;s/-$_codename//;s/-/+/g"
+}
+
+prepare() {
+ cd "$srcdir/ThiefMD"
+ git submodule init
+ git config submodule.src/ultheme-vala.url $srcdir/mysubmodule
+ git config submodule.src/libwritegood-vala.url $srcdir/mysubmodule
+ git submodule update
+}
build() {
- meson \
- --prefix /usr \
- --libexecdir lib \
- --sbindir bin \
- --buildtype plain \
- --auto-features enabled \
- -D b_lto=true \
- -D b_pie=true \
- ThiefMD-$pkgver-$_codename build
+ arch-meson ThiefMD build
meson compile -C build
}