summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 21:33:53 +0200
committerChristian Hesse2015-06-29 21:33:53 +0200
commit67282d56ee07926b53da0fb59159057e91ea2d02 (patch)
tree2e2f7b31c774f7d21ed389fe74c621bf0e8e0a04
downloadaur-thin-provisioning-tools-git.tar.gz
initial import of thin-provisioning-tools-git 0.4.0.r0.g39990e6-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af042abb8f57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = thin-provisioning-tools-git
+ pkgdesc = A suite of tools for manipulating the metadata of the dm-thin device-mapper target - git checkout
+ pkgver = 0.4.0.r0.g39990e6
+ pkgrel = 1
+ url = https://github.com/jthornber/thin-provisioning-tools
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = boost
+ makedepends = git
+ depends = expat
+ depends = gcc-libs
+ provides = thin-provisioning-tools
+ conflicts = thin-provisioning-tools
+ source = git://github.com/jthornber/thin-provisioning-tools.git
+ sha256sums = SKIP
+
+pkgname = thin-provisioning-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2276d9608df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+# Contributor: Jason Hall <cakersq@gmail.com>
+
+pkgname=thin-provisioning-tools-git
+pkgver=0.4.0.r0.g39990e6
+pkgrel=1
+pkgdesc='A suite of tools for manipulating the metadata of the dm-thin device-mapper target - git checkout'
+arch=('i686' 'x86_64')
+url='https://github.com/jthornber/thin-provisioning-tools'
+license=('GPL3')
+depends=('expat' 'gcc-libs')
+makedepends=('boost' 'git')
+provides=('thin-provisioning-tools')
+conflicts=('thin-provisioning-tools')
+source=('git://github.com/jthornber/thin-provisioning-tools.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd thin-provisioning-tools/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd thin-provisioning-tools/
+
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd thin-provisioning-tools/
+
+ make DESTDIR="${pkgdir}" BINDIR="${pkgdir}"/usr/bin MANDIR=/usr/share/man install
+}
+