summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Preinstorfer2015-07-09 10:27:13 +0200
committerFlorian Preinstorfer2015-07-09 10:27:13 +0200
commit2a19d5ff8d0ff87cb18bd30b5186887daad8326a (patch)
treeb1c55f9c576ced23a962fcba8e9102fe72983882
parentc9326db4be0664601b3470ea4439762fb19b7070 (diff)
downloadaur-2a19d5ff8d0ff87cb18bd30b5186887daad8326a.tar.gz
Implement suggestions by @Alad.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD40
2 files changed, 23 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2e69a11f9d2..ba6934d637c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = thinkfan
pkgdesc = A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi
pkgver = 0.9.2
- pkgrel = 2
+ pkgrel = 3
url = http://thinkfan.sourceforge.net/
install = thinkfan.install
arch = i686
@@ -11,13 +11,11 @@ pkgbase = thinkfan
depends = libatasmart
optdepends = lm_sensors: hwmon support
source = http://downloads.sourceforge.net/project/thinkfan/thinkfan-0.9.2.tar.gz
- source = thinkfan.install
source = thinkfan.service
source = thinkpad_acpi.conf
- md5sums = 4292633aebd61b91f04cd332c4d3e181
- md5sums = 76553f63dc55a6e09a429bb4e28eb649
- md5sums = 656b3721d0fccd770f615531f50ce0aa
- md5sums = bca920d066846e5811a2465aefa13012
+ sha256sums = 90daa0f2db221e1d5085d7f25cb6c63608d174db2987478c340e9523e652af79
+ sha256sums = 90f0270b4044a41315feb7bc1447ce4a0d5ee50178682e9a1d2a36b07c1a494f
+ sha256sums = 28874576641b3cc1aa486e1bc9ed40eadfe8b13d6d3014016e31fedc5dc5195f
pkgname = thinkfan
diff --git a/PKGBUILD b/PKGBUILD
index df9b4d0104a2..51a3d07b5541 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,37 @@
# Maintainer: nblock <nblock [/at\] archlinux DOT us>
-# Contributor: Frederik Alkærsig (FALKER) <havnelisten AT gmail.com>
+# Contributor: Frederik Alkærsig (FALKER) <havnelisten AT gmail.com>
pkgname=thinkfan
pkgver=0.9.2
-pkgrel=2
+pkgrel=3
pkgdesc="A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi"
+url="http://thinkfan.sourceforge.net/"
arch=('i686' 'x86_64')
makedepends=('cmake')
depends=('libatasmart')
optdepends=('lm_sensors: hwmon support')
license=('GPL')
-source=(http://downloads.sourceforge.net/project/${pkgname}/${pkgname}-${pkgver}.tar.gz
- "thinkfan.install" "thinkfan.service" "thinkpad_acpi.conf")
-url="http://thinkfan.sourceforge.net/"
-install="thinkfan.install"
-md5sums=('4292633aebd61b91f04cd332c4d3e181'
- '76553f63dc55a6e09a429bb4e28eb649'
- '656b3721d0fccd770f615531f50ce0aa'
- 'bca920d066846e5811a2465aefa13012')
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.gz
+ 'thinkfan.service'
+ 'thinkpad_acpi.conf')
+sha256sums=('90daa0f2db221e1d5085d7f25cb6c63608d174db2987478c340e9523e652af79'
+ '90f0270b4044a41315feb7bc1447ce4a0d5ee50178682e9a1d2a36b07c1a494f'
+ '28874576641b3cc1aa486e1bc9ed40eadfe8b13d6d3014016e31fedc5dc5195f')
+install=thinkfan.install
build() {
- cd ${srcdir}
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUSE_ATASMART:BOOL=ON
- make
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUSE_ATASMART:BOOL=ON
+ make
}
package() {
- cd ${srcdir}
- install -D -m755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
- install -D -m644 ${srcdir}/thinkpad_acpi.conf ${pkgdir}/usr/lib/modprobe.d/thinkpad_acpi.conf
- install -D -m644 README ${pkgdir}/usr/share/doc/${pkgname}/README
- install -D -m644 NEWS ${pkgdir}/usr/share/doc/${pkgname}/NEWS
- install -D -m644 ${srcdir}/${pkgname}.service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
- install -D -m644 ${pkgname}.1 ${pkgdir}/usr/share/man/man1/${pkgname}.1
- cp -r examples ${pkgdir}/usr/share/doc/${pkgname}/
+ install -d -m755 "$pkgdir"/usr/{bin,lib/{modprobe.d,systemd/system},share/{doc/"$pkgname"/{,examples},man/man1}}
+ install -D -m755 "$pkgname" "$pkgdir"/usr/bin
+ install -D -m644 thinkpad_acpi.conf "$pkgdir"/usr/lib/modprobe.d
+ install -D -m644 README NEWS "$pkgdir"/usr/share/doc/"$pkgname"
+ install -D -m644 examples/* "$pkgdir"/usr/share/doc/"$pkgname"/examples
+ install -D -m644 "$pkgname".service "$pkgdir"/usr/lib/systemd/system
+ install -D -m644 "$pkgname".1 "$pkgdir"/usr/share/man/man1
}
# vim:set ts=2 sw=2 noet: