summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Preinstorfer2016-05-05 12:23:14 +0200
committerFlorian Preinstorfer2016-05-05 12:23:14 +0200
commita427971b26036ed0e515aadc6167202acdacd507 (patch)
tree5bd512fbeeab6adfb4f3997312df18ab1e97d7cb
parent2a19d5ff8d0ff87cb18bd30b5186887daad8326a (diff)
downloadaur-a427971b26036ed0e515aadc6167202acdacd507.tar.gz
Release 0.9.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba6934d637c2..e7f57d2ff4c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu May 5 10:22:47 UTC 2016
pkgbase = thinkfan
pkgdesc = A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi
- pkgver = 0.9.2
- pkgrel = 3
+ pkgver = 0.9.3
+ pkgrel = 1
url = http://thinkfan.sourceforge.net/
install = thinkfan.install
arch = i686
@@ -10,10 +12,10 @@ pkgbase = thinkfan
makedepends = cmake
depends = libatasmart
optdepends = lm_sensors: hwmon support
- source = http://downloads.sourceforge.net/project/thinkfan/thinkfan-0.9.2.tar.gz
+ source = http://downloads.sourceforge.net/project/thinkfan/thinkfan-0.9.3.tar.gz
source = thinkfan.service
source = thinkpad_acpi.conf
- sha256sums = 90daa0f2db221e1d5085d7f25cb6c63608d174db2987478c340e9523e652af79
+ sha256sums = b61c634996c450445d7e440bf41f7adcda86506063f832afa40d44e01061e45b
sha256sums = 90f0270b4044a41315feb7bc1447ce4a0d5ee50178682e9a1d2a36b07c1a494f
sha256sums = 28874576641b3cc1aa486e1bc9ed40eadfe8b13d6d3014016e31fedc5dc5195f
diff --git a/PKGBUILD b/PKGBUILD
index 51a3d07b5541..9f3c1ba44fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Frederik Alkærsig (FALKER) <havnelisten AT gmail.com>
pkgname=thinkfan
-pkgver=0.9.2
-pkgrel=3
+pkgver=0.9.3
+pkgrel=1
pkgdesc="A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi"
url="http://thinkfan.sourceforge.net/"
arch=('i686' 'x86_64')
@@ -14,24 +14,28 @@ license=('GPL')
source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.gz
'thinkfan.service'
'thinkpad_acpi.conf')
-sha256sums=('90daa0f2db221e1d5085d7f25cb6c63608d174db2987478c340e9523e652af79'
+sha256sums=('b61c634996c450445d7e440bf41f7adcda86506063f832afa40d44e01061e45b'
'90f0270b4044a41315feb7bc1447ce4a0d5ee50178682e9a1d2a36b07c1a494f'
'28874576641b3cc1aa486e1bc9ed40eadfe8b13d6d3014016e31fedc5dc5195f')
install=thinkfan.install
build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUSE_ATASMART:BOOL=ON
make
}
package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
install -d -m755 "$pkgdir"/usr/{bin,lib/{modprobe.d,systemd/system},share/{doc/"$pkgname"/{,examples},man/man1}}
install -D -m755 "$pkgname" "$pkgdir"/usr/bin
- install -D -m644 thinkpad_acpi.conf "$pkgdir"/usr/lib/modprobe.d
install -D -m644 README NEWS "$pkgdir"/usr/share/doc/"$pkgname"
install -D -m644 examples/* "$pkgdir"/usr/share/doc/"$pkgname"/examples
- install -D -m644 "$pkgname".service "$pkgdir"/usr/lib/systemd/system
- install -D -m644 "$pkgname".1 "$pkgdir"/usr/share/man/man1
+ install -D -m644 src/"$pkgname".1 "$pkgdir"/usr/share/man/man1
+ install -D -m644 ../"$pkgname".service "$pkgdir"/usr/lib/systemd/system
+ install -D -m644 ../thinkpad_acpi.conf "$pkgdir"/usr/lib/modprobe.d
}
# vim:set ts=2 sw=2 noet: