summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Preinstorfer2015-06-08 19:41:49 +0200
committerFlorian Preinstorfer2015-06-08 19:41:49 +0200
commitc9326db4be0664601b3470ea4439762fb19b7070 (patch)
treeb2fb0dab988569050a46060d7d7bb5b70937d4fd
downloadaur-c9326db4be0664601b3470ea4439762fb19b7070.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
-rw-r--r--thinkfan.install40
-rw-r--r--thinkfan.service13
-rw-r--r--thinkpad_acpi.conf1
6 files changed, 135 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..9df60e4f24cc
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = thinkfan
+ pkgdesc = A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi
+ pkgver = 0.9.2
+ pkgrel = 2
+ url = http://thinkfan.sourceforge.net/
+ install = thinkfan.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = libatasmart
+ optdepends = lm_sensors: hwmon support
+ source = http://downloads.sourceforge.net/project/thinkfan/thinkfan-0.9.2.tar.gz
+ source = thinkfan.install
+ source = thinkfan.service
+ source = thinkpad_acpi.conf
+
+pkgname = thinkfan
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2e69a11f9d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = thinkfan
+ pkgdesc = A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi
+ pkgver = 0.9.2
+ pkgrel = 2
+ url = http://thinkfan.sourceforge.net/
+ install = thinkfan.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = libatasmart
+ optdepends = lm_sensors: hwmon support
+ source = http://downloads.sourceforge.net/project/thinkfan/thinkfan-0.9.2.tar.gz
+ source = thinkfan.install
+ source = thinkfan.service
+ source = thinkpad_acpi.conf
+ md5sums = 4292633aebd61b91f04cd332c4d3e181
+ md5sums = 76553f63dc55a6e09a429bb4e28eb649
+ md5sums = 656b3721d0fccd770f615531f50ce0aa
+ md5sums = bca920d066846e5811a2465aefa13012
+
+pkgname = thinkfan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df9b4d0104a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: nblock <nblock [/at\] archlinux DOT us>
+# Contributor: Frederik Alkærsig (FALKER) <havnelisten AT gmail.com>
+
+pkgname=thinkfan
+pkgver=0.9.2
+pkgrel=2
+pkgdesc="A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi"
+arch=('i686' 'x86_64')
+makedepends=('cmake')
+depends=('libatasmart')
+optdepends=('lm_sensors: hwmon support')
+license=('GPL')
+source=(http://downloads.sourceforge.net/project/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ "thinkfan.install" "thinkfan.service" "thinkpad_acpi.conf")
+url="http://thinkfan.sourceforge.net/"
+install="thinkfan.install"
+md5sums=('4292633aebd61b91f04cd332c4d3e181'
+ '76553f63dc55a6e09a429bb4e28eb649'
+ '656b3721d0fccd770f615531f50ce0aa'
+ 'bca920d066846e5811a2465aefa13012')
+
+build() {
+ cd ${srcdir}
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUSE_ATASMART:BOOL=ON
+ make
+}
+
+package() {
+ cd ${srcdir}
+ install -D -m755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -D -m644 ${srcdir}/thinkpad_acpi.conf ${pkgdir}/usr/lib/modprobe.d/thinkpad_acpi.conf
+ install -D -m644 README ${pkgdir}/usr/share/doc/${pkgname}/README
+ install -D -m644 NEWS ${pkgdir}/usr/share/doc/${pkgname}/NEWS
+ install -D -m644 ${srcdir}/${pkgname}.service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
+ install -D -m644 ${pkgname}.1 ${pkgdir}/usr/share/man/man1/${pkgname}.1
+ cp -r examples ${pkgdir}/usr/share/doc/${pkgname}/
+}
+
+# vim:set ts=2 sw=2 noet:
diff --git a/thinkfan.install b/thinkfan.install
new file mode 100644
index 000000000000..ecf947a7d7cd
--- /dev/null
+++ b/thinkfan.install
@@ -0,0 +1,40 @@
+# This is an install file for thinkfan package.
+
+_update() {
+ echo "Please configure thinkfan in: /etc/thinkfan.conf"
+ echo "Have a look at the examples in: /usr/share/doc/thinkfan/examples for details."
+}
+
+## arg 1: the new package version
+pre_install() {
+ :
+}
+
+# arg 1: the new package version
+post_install() {
+ _update
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ :
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ _update
+}
+
+# arg 1: the old package version
+pre_remove() {
+ :
+}
+
+# arg 1: the old package version
+post_remove() {
+ :
+}
+
+# vim:set ts=2 sw=2 noet:
diff --git a/thinkfan.service b/thinkfan.service
new file mode 100644
index 000000000000..5618aed6fe7c
--- /dev/null
+++ b/thinkfan.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=simple and lightweight fan control program
+Wants=lm_sensors.service
+After=lm_sensors.service
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/thinkfan
+PIDFile=/var/run/thinkfan.pid
+ExecReload=/usr/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target
diff --git a/thinkpad_acpi.conf b/thinkpad_acpi.conf
new file mode 100644
index 000000000000..00e1014b8216
--- /dev/null
+++ b/thinkpad_acpi.conf
@@ -0,0 +1 @@
+options thinkpad_acpi fan_control=1