summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsixsixfive2016-02-03 00:42:30 +0100
committersixsixfive2016-02-03 00:42:30 +0100
commit2c56961f89f61fbf93b57d1067ad0ab4caccbf17 (patch)
treed548cefab9ec26a327393050739238c2c7f52b05
parentc7a77eaf2bc6ef7f0759ce23378cbecf8f585cee (diff)
downloadaur-2c56961f89f61fbf93b57d1067ad0ab4caccbf17.tar.gz
proper depends
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aff04f5ac30c..783f0a8c105e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Dec 17 16:28:02 UTC 2015
+# Tue Feb 2 23:42:13 UTC 2016
pkgbase = thinkfan-git
- pkgdesc = Thinkfan is a simple, lightweight fan control program. Originally designed specifically for IBM/Lenovo Thinkpads, it now supports any kind of system via the sysfs hwmon interface (/sys/class/hwmon). It is designed to eat as little CPU power as possible.
+ pkgdesc = rewrite of Thinkfan in C++11
pkgver = 1.0.r150
pkgrel = 1
- url = http://thinkfan.sourceforge.net
+ url = https://raw.githubusercontent.com/vmatare/thinkfan/master/README
arch = i686
arch = x86_64
license = GPL3
@@ -21,6 +21,9 @@ pkgbase = thinkfan-git
pkgname = thinkfan-openrc
install = openrc.install
+ depends = libatasmart
+ depends = lm_sensors
+ depends = openrc
pkgname = thinkfan-systemd
install = systemd.install
diff --git a/PKGBUILD b/PKGBUILD
index f4521302a519..d3eefccf27b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,12 @@ pkgbase=thinkfan-git
pkgname=('thinkfan-openrc' 'thinkfan-systemd')
pkgver=1.0.r150
pkgrel=1
-pkgdesc="Thinkfan is a simple, lightweight fan control program. Originally designed
-specifically for IBM/Lenovo Thinkpads, it now supports any kind of system via
-the sysfs hwmon interface (/sys/class/hwmon). It is designed to eat as little
-CPU power as possible."
+pkgdesc="rewrite of Thinkfan in C++11"
arch=('i686' 'x86_64')
-url="http://thinkfan.sourceforge.net"
+url="https://raw.githubusercontent.com/vmatare/thinkfan/master/README"
license=('GPL3')
makedepends=('git' 'cmake' 'make' 'sed')
optdepends=('libatasmart: read HDD temperatures' 'lm_sensors: hwmon support')
-#source=("$pkgname::git://git.code.sf.net/p/thinkfan/code#branch=master")
-##using new fork!
source=("${pkgbase}::git://github.com/vmatare/thinkfan#branch=master")
md5sums=('SKIP')
@@ -50,7 +45,6 @@ commonstuff() {
provides=("${pkgname}=$pkgver" "${pkgname}-git=$pkgver")
conflicts=("${pkgname}<=$pkgver" "${pkgname}-git<=$pkgver")
replaces=("${pkgname}<=$pkgver" "${pkgname}-git<=$pkgver")
- depends+=('openrc')
cd "${pkgbase}"
make install DESTDIR="${pkgdir}"
install -d "${pkgdir}"/etc
@@ -64,6 +58,7 @@ commonstuff() {
package_thinkfan-openrc() {
install="openrc.install"
+ depends+=('openrc')
commonstuff
sed -i 's|#!/sbin/runscript|#!/usr/bin/openrc-run|' rcscripts/thinkfan.gentoo
install -Dm755 rcscripts/thinkfan.gentoo "${pkgdir}"/etc/init.d/thinkfan