summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsixsixfive2015-12-17 17:28:12 +0100
committersixsixfive2015-12-17 17:28:12 +0100
commitc7a77eaf2bc6ef7f0759ce23378cbecf8f585cee (patch)
tree9d578fba19fab058fa306e3ca1a3f83348cbb344
parentedcab1a820abcb0d4d4d552e7337ee3ef4daded1 (diff)
downloadaur-c7a77eaf2bc6ef7f0759ce23378cbecf8f585cee.tar.gz
cleaning a bit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
2 files changed, 18 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b61c0dd60f99..aff04f5ac30c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 15 04:30:31 UTC 2015
+# Thu Dec 17 16:28:02 UTC 2015
pkgbase = thinkfan-git
pkgdesc = Thinkfan is a simple, lightweight fan control program. Originally designed specifically for IBM/Lenovo Thinkpads, it now supports any kind of system via the sysfs hwmon interface (/sys/class/hwmon). It is designed to eat as little CPU power as possible.
- pkgver = 1.0.r143
+ pkgver = 1.0.r150
pkgrel = 1
url = http://thinkfan.sourceforge.net
arch = i686
@@ -21,25 +21,7 @@ pkgbase = thinkfan-git
pkgname = thinkfan-openrc
install = openrc.install
- depends = libatasmart
- depends = lm_sensors
- depends = openrc
- provides = thinkfan-openrc=1.0.r143
- provides = thinkfan-openrc-git=1.0.r143
- conflicts = thinkfan-openrc<=1.0.r143
- conflicts = thinkfan-openrc-git<=1.0.r143
- replaces = thinkfan-openrc<=1.0.r143
- replaces = thinkfan-openrc-git<=1.0.r143
pkgname = thinkfan-systemd
install = systemd.install
- depends = libatasmart
- depends = lm_sensors
- depends = systemd
- provides = thinkfan-systemd=1.0.r143
- provides = thinkfan-systemd-git=1.0.r143
- conflicts = thinkfan-systemd<=1.0.r143
- conflicts = thinkfan-systemd-git<=1.0.r143
- replaces = thinkfan-systemd<=1.0.r143
- replaces = thinkfan-systemd-git<=1.0.r143
diff --git a/PKGBUILD b/PKGBUILD
index e2949777084f..f4521302a519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=thinkfan-git
pkgname=('thinkfan-openrc' 'thinkfan-systemd')
-pkgver=1.0.r143
+pkgver=1.0.r150
pkgrel=1
pkgdesc="Thinkfan is a simple, lightweight fan control program. Originally designed
specifically for IBM/Lenovo Thinkpads, it now supports any kind of system via
@@ -15,15 +15,15 @@ makedepends=('git' 'cmake' 'make' 'sed')
optdepends=('libatasmart: read HDD temperatures' 'lm_sensors: hwmon support')
#source=("$pkgname::git://git.code.sf.net/p/thinkfan/code#branch=master")
##using new fork!
-source=("$pkgbase::git://github.com/vmatare/thinkfan#branch=master")
+source=("${pkgbase}::git://github.com/vmatare/thinkfan#branch=master")
md5sums=('SKIP')
###if installed add to deps
if (pacman -Q libatasmart >/dev/null); then
- depends+=('libatasmart')
+ depends+=('libatasmart')
fi
if (pacman -Q lm_sensors >/dev/null); then
- depends+=('lm_sensors')
+ depends+=('lm_sensors')
fi
pkgver() {
@@ -37,50 +37,41 @@ build() {
if (pacman -Q libatasmart >/dev/null); then
msg "building against libatasmart"
cmake -DUSE_ATASMART:BOOL=ON -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DUSE_NVML=OFF -DCMAKE_INSTALL_SBINDIR=/usr/bin .
+ -DUSE_NVML=ON -DCMAKE_INSTALL_SBINDIR=/usr/bin .
else
msg "building without libatasmart"
cmake -DUSE_ATASMART:BOOL=OFF -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DUSE_NVML=OFF -DCMAKE_INSTALL_SBINDIR=/usr/bin .
+ -DUSE_NVML=ON -DCMAKE_INSTALL_SBINDIR=/usr/bin .
fi
make
}
-package_thinkfan-openrc() {
+commonstuff() {
provides=("${pkgname}=$pkgver" "${pkgname}-git=$pkgver")
conflicts=("${pkgname}<=$pkgver" "${pkgname}-git<=$pkgver")
replaces=("${pkgname}<=$pkgver" "${pkgname}-git<=$pkgver")
depends+=('openrc')
- install="openrc.install"
cd "${pkgbase}"
make install DESTDIR="${pkgdir}"
install -d "${pkgdir}"/etc
-###let this thing run at full speed(7) unitl configured
+###let this thing run at full speed(7) until configured
printf "#full speed see /usr/share/doc/thinkfan for proper configuration\n(7,0,32767)\n" > "${pkgdir}"/etc/thinkfan.conf
-###not really needed
- sed -i 's|#!/sbin/runscript|#!/usr/bin/openrc-run|' rcscripts/thinkfan.gentoo
- install -Dm755 rcscripts/thinkfan.gentoo "${pkgdir}"/etc/init.d/thinkfan
install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/thinkfan/COPYING
###thinkpad modules load
install -d "${pkgdir}"/etc/modprobe.d
printf "options thinkpad_acpi fan_control=1" > "${pkgdir}"/etc/modprobe.d/thinkfan-thinkpad.conf
}
+package_thinkfan-openrc() {
+ install="openrc.install"
+ commonstuff
+ sed -i 's|#!/sbin/runscript|#!/usr/bin/openrc-run|' rcscripts/thinkfan.gentoo
+ install -Dm755 rcscripts/thinkfan.gentoo "${pkgdir}"/etc/init.d/thinkfan
+}
+
package_thinkfan-systemd() {
- provides=("${pkgname}=$pkgver" "${pkgname}-git=$pkgver")
- conflicts=("${pkgname}<=$pkgver" "${pkgname}-git<=$pkgver")
- replaces=("${pkgname}<=$pkgver" "${pkgname}-git<=$pkgver")
- depends+=('systemd')
install="systemd.install"
- cd "${pkgbase}"
- make install DESTDIR="${pkgdir}"
- install -d "${pkgdir}"/etc
-###let this thing run at full speed(7) unitl configured
- printf "#full speed see /usr/share/doc/thinkfan for proper configuration\n(7,0,32767)\n" > "${pkgdir}"/etc/thinkfan.conf
+ commonstuff
install -Dm644 rcscripts/thinkfan.service "${pkgdir}"/usr/lib/systemd/system/thinkfan.service
- install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/thinkfan/COPYING
-###thinkpad modules load
- install -d "${pkgdir}"/etc/modprobe.d
- printf "options thinkpad_acpi fan_control=1" > "${pkgdir}"/etc/modprobe.d/thinkfan-thinkpad.conf
}