summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsixsixfive2015-12-15 05:30:38 +0100
committersixsixfive2015-12-15 05:30:38 +0100
commitedcab1a820abcb0d4d4d552e7337ee3ef4daded1 (patch)
treeef97b81643fe2dc45c958b0861b3f322c0b80a1d
parent3339671102c239cac821dc8dd67b3b97e75a0fa3 (diff)
downloadaur-edcab1a820abcb0d4d4d552e7337ee3ef4daded1.tar.gz
apparently there are people who use spaces on linux file systems...
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD35
-rw-r--r--openrc.install4
-rw-r--r--systemd.install4
4 files changed, 25 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a007df2560c8..b61c0dd60f99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Dec 15 02:58:34 UTC 2015
+# Tue Dec 15 04:30:31 UTC 2015
pkgbase = thinkfan-git
pkgdesc = Thinkfan is a simple, lightweight fan control program. Originally designed specifically for IBM/Lenovo Thinkpads, it now supports any kind of system via the sysfs hwmon interface (/sys/class/hwmon). It is designed to eat as little CPU power as possible.
pkgver = 1.0.r143
diff --git a/PKGBUILD b/PKGBUILD
index b5b537f3b9fd..e2949777084f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,13 +27,13 @@ if (pacman -Q lm_sensors >/dev/null); then
fi
pkgver() {
- cd ${pkgbase}
+ cd "${pkgbase}"
_rev=$(git rev-list --count HEAD)
printf "1.0.r$_rev"
}
build() {
- cd ${pkgbase}
+ cd "${pkgbase}"
if (pacman -Q libatasmart >/dev/null); then
msg "building against libatasmart"
cmake -DUSE_ATASMART:BOOL=ON -DCMAKE_INSTALL_PREFIX:PATH=/usr \
@@ -52,18 +52,18 @@ package_thinkfan-openrc() {
replaces=("${pkgname}<=$pkgver" "${pkgname}-git<=$pkgver")
depends+=('openrc')
install="openrc.install"
- cd ${pkgbase}
- make install DESTDIR=${pkgdir}
- install -d ${pkgdir}/etc
+ cd "${pkgbase}"
+ make install DESTDIR="${pkgdir}"
+ install -d "${pkgdir}"/etc
###let this thing run at full speed(7) unitl configured
- printf "#full speed see /usr/share/doc/thinkfan for proper configuration\n(7,0,32767)\n" > ${pkgdir}/etc/thinkfan.conf
+ printf "#full speed see /usr/share/doc/thinkfan for proper configuration\n(7,0,32767)\n" > "${pkgdir}"/etc/thinkfan.conf
###not really needed
sed -i 's|#!/sbin/runscript|#!/usr/bin/openrc-run|' rcscripts/thinkfan.gentoo
- install -Dm755 rcscripts/thinkfan.gentoo ${pkgdir}/etc/init.d/thinkfan
- install -Dm644 COPYING ${pkgdir}/usr/share/licenses/thinkfan/COPYING
+ install -Dm755 rcscripts/thinkfan.gentoo "${pkgdir}"/etc/init.d/thinkfan
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/thinkfan/COPYING
###thinkpad modules load
- install -d ${pkgdir}/etc/modprobe.d
- printf "options thinkpad_acpi fan_control=1" > ${pkgdir}/etc/modprobe.d/thinkfan-thinkpad.conf
+ install -d "${pkgdir}"/etc/modprobe.d
+ printf "options thinkpad_acpi fan_control=1" > "${pkgdir}"/etc/modprobe.d/thinkfan-thinkpad.conf
}
package_thinkfan-systemd() {
@@ -72,14 +72,15 @@ package_thinkfan-systemd() {
replaces=("${pkgname}<=$pkgver" "${pkgname}-git<=$pkgver")
depends+=('systemd')
install="systemd.install"
- cd ${pkgbase}
- make install DESTDIR=${pkgdir}
- install -d ${pkgdir}/etc
+ cd "${pkgbase}"
+ make install DESTDIR="${pkgdir}"
+ install -d "${pkgdir}"/etc
###let this thing run at full speed(7) unitl configured
- printf "#full speed see /usr/share/doc/thinkfan for proper configuration\n(7,0,32767)\n" > ${pkgdir}/etc/thinkfan.conf
- install -Dm644 rcscripts/thinkfan.service ${pkgdir}/usr/lib/systemd/system/thinkfan.service
+ printf "#full speed see /usr/share/doc/thinkfan for proper configuration\n(7,0,32767)\n" > "${pkgdir}"/etc/thinkfan.conf
+ install -Dm644 rcscripts/thinkfan.service "${pkgdir}"/usr/lib/systemd/system/thinkfan.service
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/thinkfan/COPYING
###thinkpad modules load
- install -d ${pkgdir}/etc/modprobe.d
- printf "options thinkpad_acpi fan_control=1" > ${pkgdir}/etc/modprobe.d/thinkfan-thinkpad.conf
+ install -d "${pkgdir}"/etc/modprobe.d
+ printf "options thinkpad_acpi fan_control=1" > "${pkgdir}"/etc/modprobe.d/thinkfan-thinkpad.conf
}
diff --git a/openrc.install b/openrc.install
index 9fd0e79f2186..d49687881d61 100644
--- a/openrc.install
+++ b/openrc.install
@@ -10,10 +10,12 @@ post_install() {
For proper configuration see README and example configurations in /usr/share/doc/thinkfan
-#2 add/enable the service:
+#2 add/enable the service at boot:
rc-update add thinkfan default
+#3 reboot!
+
EOF
sleep 5
}
diff --git a/systemd.install b/systemd.install
index adc72ecb075f..bb1359aae704 100644
--- a/systemd.install
+++ b/systemd.install
@@ -10,10 +10,12 @@ post_install() {
For proper configuration see README and example configurations in /usr/share/doc/thinkfan
-#2 add/enable the service:
+#2 add/enable the service at boot:
systemctl enable thinkfan.service
+#3 reboot!
+
EOF
sleep 5
}