summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-04-03 06:37:53 +0000
committerAntonio Rojas2019-04-03 06:37:53 +0000
commit58234efb3a475bc89eacc497ad2a49a7410cbcf5 (patch)
tree503acbd4935016c74d936d865060d88439d849cf
downloadaur-58234efb3a475bc89eacc497ad2a49a7410cbcf5.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--gcc46.patch22
-rw-r--r--thinkfinger-uinput-hack.patch13
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ea36da06fce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = thinkfinger
+ pkgdesc = A driver for the SGS Thomson Microelectronics fingerprint reader found in most IBM/Lenovo ThinkPads
+ pkgver = 0.3
+ pkgrel = 9
+ url = http://thinkfinger.sourceforge.net/
+ arch = x86_64
+ license = GPL
+ depends = pam
+ depends = libusb-compat
+ options = emptydirs
+ source = http://downloads.sourceforge.net/thinkfinger/thinkfinger-0.3.tar.gz
+ source = thinkfinger-uinput-hack.patch
+ source = gcc46.patch
+ md5sums = 588565233bcbea5ff0a7f5314361c380
+ md5sums = 71dc334282d19e6db4f6254542ba563c
+ md5sums = 93c80f342329a5bd40f5f324fe670225
+
+pkgname = thinkfinger
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ead5a5238141
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Tom Gundersen <teg@jklm.no>
+# Contributor: François Charette <francois.archlinux.org>
+# Contributor: Damir Perisa <damir.archlinux.org>
+# Contributor: Björn Martensen <bjoern.martensen@gmail.com>
+
+pkgname=thinkfinger
+pkgver=0.3
+pkgrel=9
+pkgdesc="A driver for the SGS Thomson Microelectronics fingerprint reader found in most IBM/Lenovo ThinkPads"
+url="http://thinkfinger.sourceforge.net/"
+arch=('x86_64')
+license=("GPL")
+depends=('pam' 'libusb-compat')
+options=('emptydirs')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'thinkfinger-uinput-hack.patch'
+ 'gcc46.patch')
+md5sums=('588565233bcbea5ff0a7f5314361c380'
+ '71dc334282d19e6db4f6254542ba563c'
+ '93c80f342329a5bd40f5f324fe670225')
+
+build() {
+ cd $pkgname-$pkgver
+
+ # Patch from Ubuntu: see http://bugs.archlinux.org/task/12580
+ patch -p0 -i "${srcdir}"/thinkfinger-uinput-hack.patch
+
+ patch -p1 -i "${srcdir}"/gcc46.patch
+
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --with-birdir=/etc/pam_thinkfinger
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ # create dir to store fingerprints
+ install -d $pkgdir/etc/pam_thinkfinger
+
+ make DESTDIR=$pkgdir install
+}
diff --git a/gcc46.patch b/gcc46.patch
new file mode 100644
index 000000000000..24e4b534faec
--- /dev/null
+++ b/gcc46.patch
@@ -0,0 +1,22 @@
+--- a/pam/Makefile.am
++++ b/pam/Makefile.am
+@@ -8,7 +8,7 @@ pam_thinkfinger_so_SOURCES = pam_thinkfinger-compat.c pam_thinkfinger-compat.h p
+ else
+ pam_thinkfinger_so_SOURCES = pam_thinkfinger-uinput.c pam_thinkfinger-uinput.h pam_thinkfinger.c
+ endif
+-pam_thinkfinger_so_LDFLAGS = -shared --strip-all -Wl,-soname,pam_thinkfinger.so -Wl,--as-needed
++pam_thinkfinger_so_LDFLAGS = -shared -Wl,-soname,pam_thinkfinger.so -Wl,--as-needed
+ pam_thinkfinger_so_CFLAGS = $(CFLAGS)
+ pam_thinkfinger_so_LDADD = $(top_builddir)/libthinkfinger/libthinkfinger.la $(PAM_LIBS) $(PTHREAD_LIBS)
+
+--- a/pam/Makefile.in
++++ b/pam/Makefile.in
+@@ -201,7 +201,7 @@ pamdir = $(SECUREDIR)
+ INCLUDES = -I$(top_srcdir)/libthinkfinger
+ @HAVE_OLD_PAM_FALSE@pam_thinkfinger_so_SOURCES = pam_thinkfinger-uinput.c pam_thinkfinger-uinput.h pam_thinkfinger.c
+ @HAVE_OLD_PAM_TRUE@pam_thinkfinger_so_SOURCES = pam_thinkfinger-compat.c pam_thinkfinger-compat.h pam_thinkfinger-uinput.c pam_thinkfinger-uinput.h pam_thinkfinger.c
+-pam_thinkfinger_so_LDFLAGS = -shared --strip-all -Wl,-soname,pam_thinkfinger.so -Wl,--as-needed
++pam_thinkfinger_so_LDFLAGS = -shared -Wl,-soname,pam_thinkfinger.so -Wl,--as-needed
+ pam_thinkfinger_so_CFLAGS = $(CFLAGS)
+ pam_thinkfinger_so_LDADD = $(top_builddir)/libthinkfinger/libthinkfinger.la $(PAM_LIBS) $(PTHREAD_LIBS)
+ all: all-am
diff --git a/thinkfinger-uinput-hack.patch b/thinkfinger-uinput-hack.patch
new file mode 100644
index 000000000000..0ac153464808
--- /dev/null
+++ b/thinkfinger-uinput-hack.patch
@@ -0,0 +1,13 @@
+#Source: http://launchpadlibrarian.net/18515541/thinkfinger-uinput-hack.patch (26-12-2008)
+Index: pam/pam_thinkfinger-uinput.c
+===================================================================
+--- pam/pam_thinkfinger-uinput.c (revision 118)
++++ pam/pam_thinkfinger-uinput.c (working copy)
+@@ -95,6 +95,7 @@
+ /* our single key keyboard */
+ i = ioctl (*fd, UI_SET_EVBIT, EV_KEY) < 0;
+ i |= ioctl (*fd, UI_SET_KEYBIT, KEY_ENTER) < 0;
++ i |= ioctl (*fd, UI_SET_KEYBIT, KEY_A) < 0;
+
+ if (write (*fd, &device, device_size) != device_size) {
+ retval = errno;