summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorultraviolet2015-07-03 21:56:37 -0600
committerultraviolet2015-07-03 21:56:37 -0600
commit553246ac1803cc1930fc08a12e2ac899a0c02f59 (patch)
tree3e74dce0791deddc97418866ff8f5ff796bcfbed
downloadaur-553246ac1803cc1930fc08a12e2ac899a0c02f59.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
3 files changed, 58 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..245ef2c34884
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = thinkpad-helix-utils
+ pkgdesc = Useful tools for the Lenovo ThinkPad Helix
+ pkgver = v2.7.r13.gb950c1a
+ pkgrel = 1
+ url = https://github.com/ultravioletnanokitty/thinkpad-helix-utils
+ arch = i686
+ arch = x86_64
+ license = WTFPL
+ makedepends = git
+ depends = xorg-xinput
+ depends = xorg-xrandr
+ source = thinkpad-helix-utils::git://github.com/ultravioletnanokitty/thinkpad-helix-utils.git
+
+pkgname = thinkpad-helix-utils
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e250ab41591a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = thinkpad-helix-utils
+ pkgdesc = Useful tools for the Lenovo ThinkPad Helix
+ pkgver = v2.7.r13.gb950c1a
+ pkgrel = 1
+ url = https://github.com/ultravioletnanokitty/thinkpad-helix-utils
+ arch = i686
+ arch = x86_64
+ license = WTFPL
+ makedepends = git
+ depends = xorg-xinput
+ depends = xorg-xrandr
+ source = thinkpad-helix-utils::git://github.com/ultravioletnanokitty/thinkpad-helix-utils.git
+ md5sums = SKIP
+
+pkgname = thinkpad-helix-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..720831c3e3fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: ultraviolet <ultravioletnanokitty@gmail.com>
+
+pkgname=thinkpad-helix-utils
+pkgver=v2.7.r13.gb950c1a
+pkgrel=1
+pkgdesc="Useful tools for the Lenovo ThinkPad Helix"
+arch=('i686' 'x86_64')
+url="https://github.com/ultravioletnanokitty/thinkpad-helix-utils"
+license=('WTFPL')
+depends=('xorg-xinput' 'xorg-xrandr')
+makedepends=('git')
+source=("$pkgname"::'git://github.com/ultravioletnanokitty/thinkpad-helix-utils.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm0755 ./helix-rotate "$pkgdir/usr/bin/helix-rotate"
+ install -Dm0644 ./helix-rotate.desktop "$pkgdir/usr/share/applications/helix-rotate.desktop"
+ install -Dm0755 ./helix-toggle-touch "$pkgdir/usr/bin/helix-toggle-touch"
+ install -Dm0644 ./helix-toggle-touch.desktop "$pkgdir/usr/share/applications/helix-toggle-touch.desktop"
+}