summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAqeel Akber2015-07-02 10:34:00 +1000
committerAqeel Akber2015-07-02 10:34:00 +1000
commite4e61a340b6db2563b7a8e68be9c44fd35b843a7 (patch)
treeae13a51a3b4d443ddf04903a0f12ffe071ed510d
downloadaur-e4e61a340b6db2563b7a8e68be9c44fd35b843a7.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
-rw-r--r--thinkpad-yoga-scripts-git.install24
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4a11ab99d32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = thinkpad-yoga-scripts-git
+ pkgdesc = A collection of scripts and systemd services for tablet functionality of the ThinkPad Yoga
+ pkgver = 20150103
+ pkgrel = 2
+ url = https://github.com/admiralakber/thinkpad-yoga-scripts
+ install = thinkpad-yoga-scripts-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = xorg-xrandr
+ depends = xorg-xinput
+ depends = xbindkeys
+ depends = kbd
+ depends = systemd
+ depends = gawk
+ optdepends = onboard: onscreen keyboard
+ optdepends = xf86-input-wacom: for digitizer support
+ source = thinkpad-yoga-scripts::git+https://github.com/admiralakber/thinkpad-yoga-scripts
+ md5sums = SKIP
+
+pkgname = thinkpad-yoga-scripts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50cc83d655da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: AdmiralAkber
+
+pkgname='thinkpad-yoga-scripts-git'
+_gitname='thinkpad-yoga-scripts'
+pkgver=20150103
+pkgrel=2
+pkgdesc='A collection of scripts and systemd services for tablet functionality of the ThinkPad Yoga'
+url="https://github.com/admiralakber/thinkpad-yoga-scripts"
+source=('thinkpad-yoga-scripts::git+https://github.com/admiralakber/thinkpad-yoga-scripts')
+license=('GPL3')
+arch=('any')
+depends=('xorg-xrandr' 'xorg-xinput' 'xbindkeys' 'kbd' 'systemd' 'gawk')
+optdepends=(
+ 'onboard: onscreen keyboard'
+ 'xf86-input-wacom: for digitizer support'
+ )
+md5sums=('SKIP')
+makedepends=('git')
+install=$pkgname.install
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/$_gitname
+
+ # Install scripts into /opt
+ mkdir -p "$pkgdir/opt/$_gitname"
+ ## Rotate scripts
+ cp -r rotate "$pkgdir/opt/$_gitname"
+ ## Wacom scripts
+ cp -r wacom "$pkgdir/opt/$_gitname"
+ ## Tablet mode
+ cp -r tablet "$pkgdir/opt/$_gitname"
+ ## Backlight script
+ cp -r backlight "$pkgdir/opt/$_gitname"
+
+ # ThinkPad Yoga Systemd Services
+ mkdir -p "$pkgdir/usr/lib/systemd/system/"
+ cp systemd/*.service "$pkgdir/usr/lib/systemd/system/"
+
+ # Install license
+ install -D -m644 "LICENSE" "$pkgdir/usr/share/licenses/$_gitname/LICENSE"
+}
+
+
+
diff --git a/thinkpad-yoga-scripts-git.install b/thinkpad-yoga-scripts-git.install
new file mode 100644
index 000000000000..b7f878c64d53
--- /dev/null
+++ b/thinkpad-yoga-scripts-git.install
@@ -0,0 +1,24 @@
+_note_services(){
+ echo ''
+ echo '(Re)start services now!'
+ echo ''
+ echo 'To enable starting of services at startup run:'
+ echo '----------------------------------------------'
+ echo 'systemctl enable wacom-proximity@<username>.service'
+ echo 'systemctl enable yoga-rotate@<username>.service'
+ echo 'systemctl enable yoga-tablet.service'
+ echo 'systemctl enable yoga-backlight.service'
+ echo ''
+ echo 'Where <username> is your login username'
+ echo ''
+ echo 'Bugs/Readme: http://github.com/admiralakber/thinkpad-yoga-scripts'
+ echo 'Check the README.md for customization and different environments'
+}
+
+post_install(){
+ _note_services
+}
+
+post_upgrade(){
+ _note_services
+}