summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Băcîrcea2015-12-04 12:47:52 +0200
committerAdrian Băcîrcea2015-12-04 12:50:41 +0200
commit36d8d2cc96ad5cac54fecedd5b0da0f1bfc057c9 (patch)
tree0e15ef5b3004650cf738f8c09ebcb8fd178fe465
downloadaur-36d8d2cc96ad5cac54fecedd5b0da0f1bfc057c9.tar.gz
Re-add thinlinc-server to new AUR
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD68
-rw-r--r--service.patch33
-rw-r--r--thinlinc-server.install4
-rw-r--r--tl-4.5.0-server.zip0
-rwxr-xr-xtlwebaccess.service9
-rwxr-xr-xtlwebadm.service8
-rwxr-xr-xvsmagent.service7
-rwxr-xr-xvsmserver.service8
9 files changed, 167 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4a293186c9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = thinlinc-server
+ pkgdesc = Cendio ThinLinc Linux Remote Desktop Server
+ pkgver = 4.5.0
+ pkgrel = 1
+ url = http://www.cendio.com/
+ install = thinlinc-server.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = python2
+ depends = net-tools
+ depends = procps-ng
+ depends = xorg-xauth
+ depends = pcsclite
+ depends = java-environment
+ source = tl-4.5.0-server.zip
+ source = tlwebaccess.service
+ source = tlwebadm.service
+ source = vsmagent.service
+ source = vsmserver.service
+ source = service.patch
+ sha256sums = 449d9480637918f0d4dcb09a2b5428a58a1458c25d8b2c545fedf4f8e45bd9a0
+ sha256sums = 430bcbc959ab363a270fd830c9db8caa057dfbfde69beb6193958c282bd03f7d
+ sha256sums = cbbf364b9303ff55a7fef434bddab7533f95b8228f045e232fd1c83b78a9a842
+ sha256sums = b64dcb2ecfb38120a3314b14c114fbf79ecdf699984db7addadd3aec644165da
+ sha256sums = 3e0fdaeca38f4750c9b369a65b7b3c84dff996e9997dbb02dbfe16dc78a09849
+ sha256sums = 635a76ce5f501608ac77b3a396faee57c4bfba82ade2d38d37e657d147a745fd
+
+pkgname = thinlinc-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7cb0170d360
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: adytzu2007 <adybac "at" gmail {dot} com>
+
+pkgname=thinlinc-server
+pkgver=4.5.0
+pkgrel=1
+pkgdesc="Cendio ThinLinc Linux Remote Desktop Server"
+arch=('i686' 'x86_64')
+url="http://www.cendio.com/"
+license=('custom')
+install=${pkgname}.install
+
+depends=('python2' 'net-tools' 'procps-ng' 'xorg-xauth' 'pcsclite'
+ 'java-environment')
+
+# to get download link, register here
+# http://www.cendio.com/downloads/server/register.py
+_archive_name=tl-${pkgver}-server
+
+source=("${_archive_name}.zip"
+ 'tlwebaccess.service'
+ 'tlwebadm.service'
+ 'vsmagent.service'
+ 'vsmserver.service'
+ 'service.patch')
+sha256sums=('449d9480637918f0d4dcb09a2b5428a58a1458c25d8b2c545fedf4f8e45bd9a0'
+ '430bcbc959ab363a270fd830c9db8caa057dfbfde69beb6193958c282bd03f7d'
+ 'cbbf364b9303ff55a7fef434bddab7533f95b8228f045e232fd1c83b78a9a842'
+ 'b64dcb2ecfb38120a3314b14c114fbf79ecdf699984db7addadd3aec644165da'
+ '3e0fdaeca38f4750c9b369a65b7b3c84dff996e9997dbb02dbfe16dc78a09849'
+ '635a76ce5f501608ac77b3a396faee57c4bfba82ade2d38d37e657d147a745fd')
+
+_extract_dir="extract"
+
+build()
+{
+ cd "${srcdir}/${_archive_name}"
+
+ cd packages
+ mkdir -p "${_extract_dir}"
+
+ for rpm in *${CARCH}*rpm *noarch*rpm; do
+ bsdtar -C "${_extract_dir}" -xf "${rpm}"
+ done
+
+ pushd "${_extract_dir}"
+
+ # Patch thinlinc-server to allow installing on a system with systemd
+ pushd "opt/thinlinc/libexec"
+ patch -p1 < ${srcdir}/service.patch
+ popd
+
+ mkdir -p "usr"
+ [[ "$CARCH" == "x86_64" ]] && mv "lib64" "usr/lib"
+
+ rm -Rf "etc/init.d"
+}
+
+package()
+{
+ cd "${srcdir}/${_archive_name}/packages/${_extract_dir}"
+
+ cp -aR * "${pkgdir}"
+
+ install -D -m0644 ${srcdir}/tlwebaccess.service ${pkgdir}/usr/lib/systemd/system/tlwebaccess.service
+ install -D -m0644 ${srcdir}/tlwebadm.service ${pkgdir}/usr/lib/systemd/system/tlwebadm.service
+ install -D -m0644 ${srcdir}/vsmagent.service ${pkgdir}/usr/lib/systemd/system/vsmagent.service
+ install -D -m0644 ${srcdir}/vsmserver.service ${pkgdir}/usr/lib/systemd/system/vsmserver.service
+}
diff --git a/service.patch b/service.patch
new file mode 100644
index 000000000000..ecb5864a2f17
--- /dev/null
+++ b/service.patch
@@ -0,0 +1,33 @@
+--- a/install_service 2013-09-21 16:14:12.767315670 +0300
++++ b/install_service 2013-09-21 16:15:01.437640075 +0300
+@@ -34,6 +34,8 @@
+ /usr/lib/lsb/install_initd /etc/init.d/${service}
+ elif [ -x /sbin/chkconfig ] ; then
+ /sbin/chkconfig --add ${service}
++elif [ -x /usr/bin/systemctl ]; then
++ echo "This system is using systemd. Assuming AUR package with .service files"
+ else
+ echo "Cannot find /usr/sbin/update-rc.d, /usr/lib/lsb/install_initd or /sbin/chkconfig. "
+ echo "Please make sure that ${service} is started automatically at boot."
+--- a/remove_service 2013-09-21 16:15:08.935387292 +0300
++++ b/remove_service 2013-09-21 16:15:46.527174878 +0300
+@@ -32,6 +32,8 @@
+ /usr/lib/lsb/remove_initd /etc/init.d/${service}
+ elif [ -x /sbin/chkconfig ]; then
+ /sbin/chkconfig --del ${service}
++elif [ -x /usr/bin/systemctl ]; then
++ echo "This system is using systemd. Assuming AUR package with .service files"
+ else
+ echo "Cannot find /usr/lib/lsb/remove_initd or /sbin/chkconfig. "
+ echo "Please make sure that ${service} is removed from the system startup scripts."
+--- a/service
++++ b/service
+@@ -13,6 +13,8 @@ if [ -x /sbin/service ] ; then
+ exec /sbin/service $1 $2
+ elif [ -x /usr/sbin/service ] ; then
+ exec /usr/sbin/service $1 $2
++elif [ -x /usr/bin/systemctl ] ; then
++ exec /usr/bin/systemctl $2 ${1}.service
+ else
+ exec /etc/init.d/$1 $2
+ fi
diff --git a/thinlinc-server.install b/thinlinc-server.install
new file mode 100644
index 000000000000..9c28c0eddfbf
--- /dev/null
+++ b/thinlinc-server.install
@@ -0,0 +1,4 @@
+post_install()
+{
+ PYTHON=/usr/bin/python2 /opt/thinlinc/sbin/tl-setup
+}
diff --git a/tl-4.5.0-server.zip b/tl-4.5.0-server.zip
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/tl-4.5.0-server.zip
diff --git a/tlwebaccess.service b/tlwebaccess.service
new file mode 100755
index 000000000000..0281d0715071
--- /dev/null
+++ b/tlwebaccess.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=ThinLinc Web Access
+
+[Service]
+Type=simple
+PIDFile=/var/run/tlwebaccess.pid
+ExecStart=/opt/thinlinc/sbin/tlwebaccess
+
+
diff --git a/tlwebadm.service b/tlwebadm.service
new file mode 100755
index 000000000000..12775da1f0ef
--- /dev/null
+++ b/tlwebadm.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=ThinLinc Web Administration
+
+[Service]
+Type=simple
+PIDFile=/var/run/tlwebadm.pid
+ExecStart=/opt/thinlinc/sbin/tlwebadm
+
diff --git a/vsmagent.service b/vsmagent.service
new file mode 100755
index 000000000000..56375a5a76d8
--- /dev/null
+++ b/vsmagent.service
@@ -0,0 +1,7 @@
+[Unit]
+Description=ThinLinc vsmagent
+
+[Service]
+Type=simple
+PIDFile=/var/run/vsmagent.pid
+ExecStart=/opt/thinlinc/sbin/vsmagent
diff --git a/vsmserver.service b/vsmserver.service
new file mode 100755
index 000000000000..7d29b5091623
--- /dev/null
+++ b/vsmserver.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=ThinLinc vsmserver
+
+[Service]
+Type=simple
+PIDFile=/var/run/vsmserver.pid
+ExecStart=/opt/thinlinc/sbin/vsmserver
+