summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-08 16:19:10 +0800
committerzxp198210052023-11-08 16:19:10 +0800
commit14e44ae5424e974c897449107afe43c402b7ab00 (patch)
tree5591dd9f8be6a324ca1fee12e5e0a6693c3ce6b5
parent81eb72a5e3a3825929106fa0f8e6cc31cc3d4913 (diff)
downloadaur-14e44ae5424e974c897449107afe43c402b7ab00.tar.gz
fix errors
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
-rw-r--r--thinreports-section-editor.sh5
3 files changed, 36 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6921d8421c9a..797dd7ea84de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
pkgbase = thinreports-section-editor-bin
pkgdesc = A template editor for Thinreports to edit Section Format templates
pkgver = 1.0.0_dev
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/thinreports/thinreports
arch = x86_64
license = MIT
+ makedepends = squashfuse
depends = bash
depends = electron21
depends = hicolor-icon-theme
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
provides = thinreports-section-editor=1.0.0_dev
conflicts = thinreports-section-editor
source = thinreports-section-editor-1.0.0_dev.AppImage::https://github.com/thinreports/thinreports-section-editor/releases/download/v1.0.0-dev/thinreports-section-editor-1.0.0-dev-linux-20221031-0b5119.AppImage
@@ -15,6 +22,6 @@ pkgbase = thinreports-section-editor-bin
source = thinreports-section-editor.sh
sha256sums = 818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb
sha256sums = 2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c
- sha256sums = 658588bf0e8ddebb7e2010fd9f840811489ea33b86ded200a5b72df10ac913c8
+ sha256sums = 548d946f04d5755697a2ac0cdfd302f35149aa694a862325c6c35d1b9c3df031
pkgname = thinreports-section-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
index ede82d6f1500..bb4fe72f05bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=thinreports-section-editor-bin
pkgver=1.0.0_dev
-pkgrel=2
+pkgrel=3
pkgdesc="A template editor for Thinreports to edit Section Format templates"
arch=('x86_64')
url="https://github.com/thinreports/thinreports"
@@ -9,21 +9,37 @@ _githuburl="https://github.com/thinreports/thinreports-section-editor"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron21' 'hicolor-icon-theme')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver//_/-}/${pkgname%-bin}-${pkgver//_/-}-linux-20221031-0b5119.AppImage"
+depends=(
+ 'bash'
+ 'electron21'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver//_/-}/${pkgname%-bin}-${pkgver//_/-}-linux-20221031-0b5119.AppImage"
"LICENSE::https://raw.githubusercontent.com/thinreports/thinreports-section-editor/v${pkgver//_/-}/LICENSE"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb'
'2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c'
- '658588bf0e8ddebb7e2010fd9f840811489ea33b86ded200a5b72df10ac913c8')
-prepare() {
+ '548d946f04d5755697a2ac0cdfd302f35149aa694a862325c6c35d1b9c3df031')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024; do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
diff --git a/thinreports-section-editor.sh b/thinreports-section-editor.sh
index 2abaefe72bce..4a5d159a6733 100644
--- a/thinreports-section-editor.sh
+++ b/thinreports-section-editor.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron21
-_ASAR="/opt/thinreports-section-editor/thinreports-section-editor.asar"
+APPDIR=/usr/lib/thinreports-section-editor
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/usr/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else