summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-19 15:59:48 +0800
committerzxp198210052024-01-19 15:59:48 +0800
commit45fdd8375280bd1210d27ff3234efd737c9316af (patch)
tree3a072f5705f752653af1c56e5f714f07fdea8b72
parent31f43394a9789f1c20f20b7e125e5c1c58895097 (diff)
downloadaur-45fdd8375280bd1210d27ff3234efd737c9316af.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--thinreports-section-editor.sh13
3 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7102de96ddf..4311031440d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,12 +8,9 @@ pkgbase = thinreports-section-editor-bin
makedepends = squashfuse
depends = electron21
depends = hicolor-icon-theme
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
provides = thinreports-section-editor=1.0.0_dev
conflicts = thinreports-section-editor
source = thinreports-section-editor-1.0.0_dev.AppImage::https://github.com/thinreports/thinreports-section-editor/releases/download/v1.0.0-dev/thinreports-section-editor-1.0.0-dev-linux-20221031-0b5119.AppImage
@@ -21,6 +18,6 @@ pkgbase = thinreports-section-editor-bin
source = thinreports-section-editor.sh
sha256sums = 818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb
sha256sums = 2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = thinreports-section-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
index 53ab2b182b31..6c47d9e12164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,9 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
@@ -30,7 +27,7 @@ source=(
)
sha256sums=('818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb'
'2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -38,7 +35,7 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/thinreports-section-editor.sh b/thinreports-section-editor.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/thinreports-section-editor.sh
+++ b/thinreports-section-editor.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file