summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-08 16:15:07 +0800
committerzxp198210052023-09-08 16:15:07 +0800
commit81eb72a5e3a3825929106fa0f8e6cc31cc3d4913 (patch)
treeface2f281de18d10d774136f6b6047a2cfb6bcb7
parentf1377dc21e1a6321a02699d4567481b91321096b (diff)
downloadaur-81eb72a5e3a3825929106fa0f8e6cc31cc3d4913.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef4659a5c736..6921d8421c9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = thinreports-section-editor-bin
pkgdesc = A template editor for Thinreports to edit Section Format templates
pkgver = 1.0.0_dev
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/thinreports/thinreports
arch = x86_64
license = MIT
depends = bash
depends = electron21
depends = hicolor-icon-theme
+ provides = thinreports-section-editor=1.0.0_dev
conflicts = thinreports-section-editor
source = thinreports-section-editor-1.0.0_dev.AppImage::https://github.com/thinreports/thinreports-section-editor/releases/download/v1.0.0-dev/thinreports-section-editor-1.0.0-dev-linux-20221031-0b5119.AppImage
- source = LICENSE::https://raw.githubusercontent.com/thinreports/thinreports-section-editor/main/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/thinreports/thinreports-section-editor/v1.0.0-dev/LICENSE
source = thinreports-section-editor.sh
sha256sums = 818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb
sha256sums = 2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c
diff --git a/PKGBUILD b/PKGBUILD
index 7cfce8fca85b..ede82d6f1500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=thinreports-section-editor-bin
pkgver=1.0.0_dev
-pkgrel=1
+pkgrel=2
pkgdesc="A template editor for Thinreports to edit Section Format templates"
arch=('x86_64')
url="https://github.com/thinreports/thinreports"
_githuburl="https://github.com/thinreports/thinreports-section-editor"
license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=('bash' 'electron21' 'hicolor-icon-theme')
source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver//_/-}/${pkgname%-bin}-${pkgver//_/-}-linux-20221031-0b5119.AppImage"
- "LICENSE::https://raw.githubusercontent.com/thinreports/thinreports-section-editor/main/LICENSE"
+ "LICENSE::https://raw.githubusercontent.com/thinreports/thinreports-section-editor/v${pkgver//_/-}/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb'
'2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c'
@@ -18,15 +19,15 @@ sha256sums=('818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb'
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024; do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
- sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file