summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-28 13:16:06 +0800
committerzxp198210052024-02-28 13:16:06 +0800
commita14dc6b4ced5e08902d48f8b4ecaaf00ce9da831 (patch)
tree370afc5b3c5dbd9e70ba703d28247afaa4ed7f6c
parent45fdd8375280bd1210d27ff3234efd737c9316af (diff)
downloadaur-a14dc6b4ced5e08902d48f8b4ecaaf00ce9da831.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--thinreports-section-editor.sh9
3 files changed, 9 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4311031440d7..f140d851d7d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,12 @@
pkgbase = thinreports-section-editor-bin
pkgdesc = A template editor for Thinreports to edit Section Format templates
pkgver = 1.0.0_dev
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/thinreports/thinreports
arch = x86_64
license = MIT
- makedepends = squashfuse
depends = electron21
depends = hicolor-icon-theme
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk2
provides = thinreports-section-editor=1.0.0_dev
conflicts = thinreports-section-editor
source = thinreports-section-editor-1.0.0_dev.AppImage::https://github.com/thinreports/thinreports-section-editor/releases/download/v1.0.0-dev/thinreports-section-editor-1.0.0-dev-linux-20221031-0b5119.AppImage
@@ -18,6 +14,6 @@ pkgbase = thinreports-section-editor-bin
source = thinreports-section-editor.sh
sha256sums = 818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb
sha256sums = 2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = thinreports-section-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6c47d9e12164..70b530fd3d09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=thinreports-section-editor-bin
pkgver=1.0.0_dev
_electronversion=21
-pkgrel=4
+pkgrel=5
pkgdesc="A template editor for Thinreports to edit Section Format templates"
arch=('x86_64')
url="https://github.com/thinreports/thinreports"
@@ -13,12 +13,6 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
-)
-makedepends=(
- 'squashfuse'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver//_/-}/${pkgname%-bin}-${pkgver//_/-}-linux-20221031-0b5119.AppImage"
@@ -27,11 +21,11 @@ source=(
)
sha256sums=('818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb'
'2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/thinreports-section-editor.sh b/thinreports-section-editor.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/thinreports-section-editor.sh
+++ b/thinreports-section-editor.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file