summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Szczuczko2016-08-04 08:02:09 -0600
committerAlex Szczuczko2016-08-04 08:02:09 -0600
commita758765bda750898b836511dbc7dfcf618cb3a1b (patch)
treed7e57f026fa6ece0f07a2ccc681c246a1a258706
parent27360d45e30a10efafc3fdff1c629252e9a6bce4 (diff)
downloadaur-a758765bda750898b836511dbc7dfcf618cb3a1b.tar.gz
Update to version 2.5.0.7
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD41
-rw-r--r--launch-thiswarofmine.sh10
3 files changed, 50 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43752ee9a0ea..be93f1667f2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,38 @@
+# Generated by mksrcinfo v8
+# Thu Aug 4 14:01:04 UTC 2016
pkgbase = thiswarofmine-gog
pkgdesc = Experience war not as a soldier, but as a group of civilians in a besieged city.
- pkgver = 1.2.0.3
+ pkgver = 2.5.0.7
pkgrel = 1
url = http://www.gog.com/game/this_war_of_mine
arch = i686
arch = x86_64
license = custom:commercial
- depends = openal
- depends = gcc-libs
- depends = glibc
- depends = libx11
- depends = libxau
- depends = libxcb
- depends = libxdmcp
- depends = libxext
- depends = libgl
options = !strip
source = thiswarofmine-gog.desktop
source = launch-thiswarofmine.sh
- source = gog_this_war_of_mine_1.2.0.3.tar.gz::file://gog_this_war_of_mine_1.2.0.3.tar.gz
+ source = gog_this_war_of_mine_2.5.0.7.sh::file://gog_this_war_of_mine_2.5.0.7.sh
sha256sums = ce9720a6f72402c354bfc12dace96609b847c96c496c2f706080a3696d38ae4e
- sha256sums = b1ac5ee88d49466585a65db109000c2c5c9cadb315aba06504abdd6ae79b168e
- sha256sums = 5b5d00a35a1d933ad4bcfefa35c86631d57cf8c72d1535e12cb4daed5a6287c6
+ sha256sums = 823c0c5c01240b29752b03a978a49a7e710f5ed4f7e1da2f31d649c47ea6f236
+ sha256sums = 68205de4f077f8fc33ab9928b8cd19875392968f6bc89a17924e28e83c6a0ad4
+ depends_i686 = openal
+ depends_i686 = gcc-libs
+ depends_i686 = glibc
+ depends_i686 = libx11
+ depends_i686 = libxau
+ depends_i686 = libxcb
+ depends_i686 = libxdmcp
+ depends_i686 = libxext
+ depends_i686 = libgl
+ depends_x86_64 = lib32-openal
+ depends_x86_64 = lib32-gcc-libs
+ depends_x86_64 = lib32-glibc
+ depends_x86_64 = lib32-libx11
+ depends_x86_64 = lib32-libxau
+ depends_x86_64 = lib32-libxcb
+ depends_x86_64 = lib32-libxdmcp
+ depends_x86_64 = lib32-libxext
+ depends_x86_64 = lib32-libgl
pkgname = thiswarofmine-gog
diff --git a/PKGBUILD b/PKGBUILD
index a79f33daa015..f3a409239902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,47 @@
# Maintainer: Alex Szczuczko <alex@szc.ca>
pkgname=thiswarofmine-gog
-pkgver=1.2.0.3
+pkgver=2.5.0.7
pkgrel=1
pkgdesc="Experience war not as a soldier, but as a group of civilians in a besieged city."
arch=("i686" "x86_64")
url="http://www.gog.com/game/this_war_of_mine"
license=("custom:commercial")
options=(!strip)
-depends=()
+depends_x86_64=("lib32-openal" "lib32-gcc-libs" "lib32-glibc" "lib32-libx11" "lib32-libxau" "lib32-libxcb" "lib32-libxdmcp" "lib32-libxext" "lib32-libgl")
+depends_i686=("openal" "gcc-libs" "glibc" "libx11" "libxau" "libxcb" "libxdmcp" "libxext" "libgl")
source=("${pkgname}.desktop"
"launch-thiswarofmine.sh"
- "gog_this_war_of_mine_${pkgver}.tar.gz::file://gog_this_war_of_mine_${pkgver}.tar.gz")
+ "gog_this_war_of_mine_${pkgver}.sh::file://gog_this_war_of_mine_${pkgver}.sh")
sha256sums=("ce9720a6f72402c354bfc12dace96609b847c96c496c2f706080a3696d38ae4e"
- "b1ac5ee88d49466585a65db109000c2c5c9cadb315aba06504abdd6ae79b168e"
- "5b5d00a35a1d933ad4bcfefa35c86631d57cf8c72d1535e12cb4daed5a6287c6")
-
-# Modify depends for the arch type
-if [ "$CARCH" = "x86_64" ]
-then
- depends+=("lib32-openal" "lib32-gcc-libs" "lib32-glibc" "lib32-libx11" "lib32-libxau" "lib32-libxcb" "lib32-libxdmcp" "lib32-libxext" "lib32-libgl")
-else
- depends+=("openal" "gcc-libs" "glibc" "libx11" "libxau" "libxcb" "libxdmcp" "libxext" "libgl")
-fi
+ "823c0c5c01240b29752b03a978a49a7e710f5ed4f7e1da2f31d649c47ea6f236"
+ "68205de4f077f8fc33ab9928b8cd19875392968f6bc89a17924e28e83c6a0ad4")
# Disable compression of the package
PKGEXT='.pkg.tar'
package() {
+ # Data
+ install -d "$pkgdir/opt/$pkgname/"
+ # Hardlink files to save the disk space and time spent copying them (they are large)
+ cp -Ral -t "$pkgdir/opt/$pkgname/" "$srcdir/data/noarch/game/."
+ find "$pkgdir/opt/$pkgname/" -type d -print0 | xargs -0 chmod 755
+ find "$pkgdir/opt/$pkgname/" -type f -print0 | xargs -0 chmod 644
+
# Binaries
- install -Dm755 "$srcdir/This War Of Mine/game/This War of Mine" "$pkgdir/opt/$pkgname/This War of Mine"
- ln -s "/usr/lib32/libopenal.so" "$pkgdir/opt/$pkgname/libOpenAL.so"
+ chmod 775 "$pkgdir/opt/$pkgname/KosovoLinux"
+ ln -fs "/usr/lib32/libopenal.so" "$pkgdir/opt/$pkgname/libOpenAL.so"
# Launcher
install -m755 -t "$pkgdir/opt/$pkgname/" "$srcdir/launch-thiswarofmine.sh"
- # Data
- find "$srcdir/This War Of Mine/game/" -maxdepth 1 -type f "(" -name "*.dat" -or -name "*.idx" ")" -print0 | \
- xargs -0 install -m644 -t "$pkgdir/opt/$pkgname/"
-
# Docs
install -m755 -d "$pkgdir/opt/$pkgname/docs"
install -m644 -t "$pkgdir/opt/$pkgname/docs" \
- "$srcdir/This War Of Mine/game/Changelog.txt" \
- "$srcdir/This War Of Mine/docs/End User License Agreement.txt"
+ "$srcdir/data/noarch/docs/End User License Agreement.txt"
# Icon
- install -m644 -t "$pkgdir/opt/$pkgname/" "$srcdir/This War Of Mine/support/gog-this-war-of-mine.png"
+ install -m644 -t "$pkgdir/opt/$pkgname/" "$srcdir/data/noarch/support/icon.png"
#
# System integration
@@ -62,7 +57,7 @@ package() {
# Icon
install -m755 -d "$pkgdir/usr/share/pixmaps/"
- ln -s "/opt/$pkgname/gog-this-war-of-mine.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+ ln -s "/opt/$pkgname/icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
# .desktop File
install -m755 -d "$pkgdir/usr/share/applications/"
diff --git a/launch-thiswarofmine.sh b/launch-thiswarofmine.sh
index 4de4c2658c1a..9f9e2077acbb 100644
--- a/launch-thiswarofmine.sh
+++ b/launch-thiswarofmine.sh
@@ -22,10 +22,16 @@ make_user_dir() {
launch_game() {
cd "$user_dir"
- ./"This War of Mine"
+ ./KosovoLinux
}
-if [ ! -f "$user_dir/This War of Mine" ]
+if [ ! -d "$user_dir/Mods" ]
+then
+ echo "Updating user directory to v2 file layout"
+ mv "$user_dir" "${user_dir}_v1"
+fi
+
+if [ ! -e "$user_dir/KosovoLinux" ]
then
make_user_dir
fi