summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Engledow2015-09-03 01:06:24 +0100
committerSteve Engledow2015-09-03 01:06:24 +0100
commit9db5879fac6b8ba61845692620a0e978dcc71800 (patch)
treed9435978136c2b5acf137beb4b06014fc6972124
downloadaur-9db5879fac6b8ba61845692620a0e978dcc71800.tar.gz
Initial commit: v0.1 of thiy
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c057492ec023
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = thiy
+ pkgdesc = A templating engine that uses YAML templates to produce HTML files.
+ pkgver = 0.1
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source_i686 = thiy-i686::https://github.com/stilvoid/thiy/releases/download/v0.1/thiy-linux-i386
+ md5sums_i686 = 880dfe5b27a3af2b9789d49130a2c47a
+ source_x86_64 = thiy-x86_64::https://github.com/stilvoid/thiy/releases/download/v0.1/thiy-linux-amd64
+ md5sums_x86_64 = 3340557cb17e0473b39473672faee73d
+
+pkgname = thiy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63d54bc2b682
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Steve Engledow <steve at offend dot me dot uk>
+pkgname=thiy
+pkgver=0.1
+pkgrel=1
+pkgdesc="A templating engine that uses YAML templates to produce HTML files."
+arch=('i686' 'x86_64')
+url=""
+license=('MIT')
+install=
+changelog=
+source=($pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums_i686=('880dfe5b27a3af2b9789d49130a2c47a')
+md5sums_x86_64=('3340557cb17e0473b39473672faee73d')
+source=()
+source_i686=("thiy-i686::https://github.com/stilvoid/$pkgname/releases/download/v$pkgver/$pkgname-linux-i386")
+source_x86_64=("thiy-x86_64::https://github.com/stilvoid/$pkgname/releases/download/v$pkgver/$pkgname-linux-amd64")
+
+package() {
+ install -Dm 755 "${srcdir}/thiy-$CARCH" "${pkgdir}/usr/bin/thiy"
+}