summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM.Reynolds2016-10-15 20:52:42 -0400
committerM.Reynolds2016-10-15 20:52:42 -0400
commit9fd4de365a924d13ec9dacf2a49562df836ef476 (patch)
tree80125a07e8f00b4961f198ac67e1653c56b15b8b
parente7e52133ec4d851eff74bbcaaa4160f74a584eea (diff)
downloadaur-9fd4de365a924d13ec9dacf2a49562df836ef476.tar.gz
Update 2.0.3 -- Some Python files in the PKGBUILD were commented as possibly unnecessary, uncomment them if there are problems.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd0aa82c22d6..3aa0cbd94d4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thonny
pkgdesc = Python IDE for beginners.
- pkgver = 2.0.0b4
+ pkgver = 2.0.3
pkgrel = 1
url = http://thonny.cs.ut.ee/
arch = any
@@ -11,8 +11,8 @@ pkgbase = thonny
depends = python-jedi
depends = tcl
depends = tk
- source = https://bitbucket.org/plas/thonny/downloads/thonny-2.0.0b4-x86_64.tar.gz
- sha256sums = 95c86ba5c783dfbbd29351fa2e057192bc0fa22c2dd4d6354f9b917836f347c5
+ source = https://bitbucket.org/plas/thonny/downloads/thonny-2.0.3-x86_64.tar.gz
+ sha256sums = 4bdb5d18d4e0b8e95c33ed3689b552b5bcb6a79c0a90f2a9e708946324d17fac
pkgname = thonny
diff --git a/PKGBUILD b/PKGBUILD
index 240bd7c11bab..2efb168177e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
pkgname=thonny
-pkgver=2.0.0b4
+pkgver=2.0.3
pkgrel=1
pkgdesc="Python IDE for beginners."
arch=('any')
@@ -9,7 +9,7 @@ url="http://thonny.cs.ut.ee/"
license=('MIT')
depends=('openssl' 'python' 'python-beautifulsoup4' 'python-jedi' 'tcl' 'tk')
source=("https://bitbucket.org/plas/$pkgname/downloads/$pkgname-$pkgver-x86_64.tar.gz")
-sha256sums=('95c86ba5c783dfbbd29351fa2e057192bc0fa22c2dd4d6354f9b917836f347c5')
+sha256sums=('4bdb5d18d4e0b8e95c33ed3689b552b5bcb6a79c0a90f2a9e708946324d17fac')
package() {
cd "$srcdir"
@@ -25,22 +25,22 @@ package() {
cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/thonny" \
"$pkgdir/usr/lib/python3.5/site-packages"
- install -d 644 "$pkgdir/usr/lib/python3.5/site-packages/thonny-$pkgver.dist-info"
- cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/thonny-$pkgver.dist-info" \
- "$pkgdir/usr/lib/python3.5/site-packages"
+ #install -d 644 "$pkgdir/usr/lib/python3.5/site-packages/thonny-$pkgver.dist-info"
+ #cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/thonny-$pkgver.dist-info" \
+ # "$pkgdir/usr/lib/python3.5/site-packages"
install -Dm 644 "$pkgname/lib/python3.5/site-packages/distro.py" \
"$pkgdir/usr/lib/python3.5/site-packages/distro.py"
- install -d 644 "$pkgdir/usr/lib/python3.5/site-packages/distro-0.6.0-py3.5.egg-info"
- cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/distro-0.6.0-py3.5.egg-info" \
- "$pkgdir/usr/lib/python3.5/site-packages"
+ #install -d 644 "$pkgdir/usr/lib/python3.5/site-packages/distro-0.6.0-py3.5.egg-info"
+ #cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/distro-0.6.0-py3.5.egg-info" \
+ # "$pkgdir/usr/lib/python3.5/site-packages"
install -d 644 "$pkgdir/usr/lib/python3.5/site-packages/tkinterhtml"
cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/tkinterhtml" \
"$pkgdir/usr/lib/python3.5/site-packages"
- install -d 644 "$pkgdir/usr/lib/python3.5/site-packages/tkinterhtml-0.7-py3.5.egg-info"
- cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/tkinterhtml-0.7-py3.5.egg-info" \
- "$pkgdir/usr/lib/python3.5/site-packages"
+ #install -d 644 "$pkgdir/usr/lib/python3.5/site-packages/tkinterhtml-0.7-py3.5.egg-info"
+ #cp -dr --no-preserve=ownership "$pkgname/lib/python3.5/site-packages/tkinterhtml-0.7-py3.5.egg-info" \
+ # "$pkgdir/usr/lib/python3.5/site-packages"
}